Bug 627174 - fedpkg co -B <package> dysfunctional
Summary: fedpkg co -B <package> dysfunctional
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 627748 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-25 09:49 UTC by Ralf Corsepius
Modified: 2013-01-10 06:10 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-19 21:04:44 UTC


Attachments (Terms of Use)

Description Ralf Corsepius 2010-08-25 09:49:12 UTC
Description of problem:


$ fedpkg co -B ddd
Cloning into bare repository /home/fedora/src/fedora/pkgs/git/ddd/fedpkg.git...
Enter passphrase for key '/home/fedora/.ssh/id_fedora': 
remote: Counting objects: 227, done.
remote: Compressing objects: 100% (92/92), done.
remote: Total 227 (delta 120), reused 227 (delta 120)
Receiving objects: 100% (227/227), 31.53 KiB, done.
Resolving deltas: 100% (120/120), done.
Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 1086, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 425, in clone
    pyfedpkg.clone_with_dirs(args.module[0], args.user)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 413, in clone_with_dirs
    clone(module, user, top_path, bare_dir=repo_path)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 385, in clone
    repo = git.Repo(module)
  File "/usr/lib/python2.6/site-packages/git/repo.py", line 116, in __init__
    raise InvalidGitRepositoryError(epath)
git.errors.InvalidGitRepositoryError: /home/fedora/src/fedora/pkgs/git/ddd

Version-Release number of selected component (if applicable):
fedpkg-0.5.1.3-1.fc13.noarch

How reproducible:
Always

Steps to Reproduce:
1. fedpkg co -B <arbitrary package>

  
Actual results:
c.f. above.

Expected results:
Function

Comment 1 Jesse Keating 2010-08-25 17:18:10 UTC
This is already fixed in the latest built fedora-packager, which should hit updates-testing today.

Comment 2 Ralf Corsepius 2010-08-26 17:11:28 UTC
(In reply to comment #1)
> This is already fixed in the latest built fedora-packager, which should hit
> updates-testing today.
On this side of the "big pond", it landed today.

Thanks, it seems to work.

Comment 3 Jesse Keating 2010-08-27 00:28:32 UTC
*** Bug 627748 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2011-01-06 18:50:00 UTC
fedora-packager-0.5.2.0-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.2.0-2.el5

Comment 5 Fedora Update System 2011-01-06 19:01:06 UTC
fedora-packager-0.5.2.0-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.2.0-2.fc13

Comment 6 Fedora Update System 2011-01-06 19:03:31 UTC
fedora-packager-0.5.2.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.2.0-2.fc14

Comment 7 Fedora Update System 2011-01-07 17:35:07 UTC
fedora-packager-0.5.2.0-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/fedora-packager-0.5.2.0-2.el5

Comment 8 Fedora Update System 2011-01-19 21:03:50 UTC
fedora-packager-0.5.2.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-01-31 15:52:04 UTC
fedora-packager-0.5.2.0-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-01-31 19:54:49 UTC
fedora-packager-0.5.2.0-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.