Bug 62723 - nsgmls does not support remote references &c
nsgmls does not support remote references &c
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: openjade (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-04 17:16 EST by sds
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 15:44:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sds 2002-04-04 17:16:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
I get this:
nsgmls:URL not supported by this version
when I try to include a remote system entiry in a Docbook/XML document

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
  <!ENTITY gfdl-text SYSTEM "http://www.gnu.org/licenses/fdl.sgml">

%gfdl-text;

Actual Results:  nsgmls:URL not supported by this version

Expected Results:  the text of GFDL is included in the docunent

Additional info:
Comment 1 Tim Waugh 2002-04-05 02:32:43 EST
I turned on HTTP support in openjade a while back in rawhide.
Comment 2 sds 2002-04-05 15:44:07 EST
thanks - but there are more problems still!

nsgmls:/etc/sgml/xml-docbook-4.1.cat:3:8:E: cannot open
"/usr/share/sgml/openjade-1.3/catalog" (No such file or directory)
(you have to fix /etc/sgml/xml-docbook-4.1.cat to point 1.3.1)

Also, the fact that such important files like xml.soc are located under
version-specific directory (/usr/share/doc/openjade-1.3.1) makes me edit a
makefile after each upgrade.  very ugly.

Also, /etc/sgml/xml-docbook-4.1.2-1.0-8.cat should be xml-docbook-4.1.2.cat
Comment 3 Tim Waugh 2002-04-05 16:38:28 EST
I think you'll need to upgrade several packages to those in rawhide to get
openjade 1.3.1 working.
Comment 4 Tim Waugh 2002-04-05 16:38:52 EST
(Better yet, try the beta release of the distribution..)

Note You need to log in before you can comment on or make changes to this bug.