Bug 62732 - ifcfg-eth* stores incorrect info. after removing some NICs
ifcfg-eth* stores incorrect info. after removing some NICs
Status: CLOSED DUPLICATE of bug 61169
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-04 18:56 EST by Danny Trinh
Modified: 2015-03-04 20:10 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-08 03:11:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Files before and after remove a NIC card (1.29 KB, application/octet-stream)
2002-04-04 18:57 EST, Danny Trinh
no flags Details

  None (edit)
Description Danny Trinh 2002-04-04 18:56:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
After installing beta4 on the server which has 3 NIC cards, I shut down and 
remove one of NIC card, then reboot server. I run ifconfig and see only 1 NIC 
(eth0). I check /etc/sysconfig/network-scripts/ifcfg-eth0 and find out that was 
incorrect info.
Below is the content of ifcfg-eth0:
DEVICE=eth1
BOOTPROTO=dhcp
ONBOOT=yes



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use PE1650 + 2 embedded NIC + 1 intel 100B
2.Install Hampton beta4. Make sure you turn on "DHCP" and "active at boot" 
options for all 3 NICs.
3.Reboot server and check ifcfg-eth* contents.
4.Shutdown server and remove the intel 100B NIC.
5.Reboot server and answer kudzu questions.
6.Run ifconfig
7.Check the contents of ifcfg-eth0 and ifcfg-eth1
	

Actual Results:  Writing wrong info to ifcfg-eth* after remove one NIC.

Expected Results:  Suppose to be correct as expected

Additional info:
Comment 1 Danny Trinh 2002-04-04 18:57:45 EST
Created attachment 52284 [details]
Files before and after remove a NIC card
Comment 2 Danny Trinh 2002-04-05 18:02:17 EST
For more info. related to this bug, please see bug# 61169
Comment 3 Bill Nottingham 2002-04-09 12:56:57 EDT

*** This bug has been marked as a duplicate of 61169 ***

Note You need to log in before you can comment on or make changes to this bug.