Bug 627328 - /sbin/service command should handle detaching systemd cgroups
/sbin/service command should handle detaching systemd cgroups
Status: CLOSED DUPLICATE of bug 612728
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-08-25 13:14 EDT by Matthew Miller
Modified: 2014-03-16 23:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-08-25 14:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2010-08-25 13:14:03 EDT
Description of problem:

If I start a service with "sudo service daemond start", it remains attached to my systemd:/user/ cgroup.

The service command should, in addition to clearing the environment

Version-Release number of selected component (if applicable):

current rawhide.

How reproducible:


Steps to Reproduce:
1. start a server with 'sudo service httpd start'
2. note the pid of the running process
3. look at /proc/<pid/cgroup 
(Note that I'm just using httpd as an example here; httpd will probably really be started by and controlled natively by systemd once this all goes into production.)

Actual results:


Expected results:

Some other cgroup, corresponding to what you'd get if the service were started by sysvinit scripts at boot time.
Comment 2 Bill Nottingham 2010-08-25 14:05:34 EDT

*** This bug has been marked as a duplicate of bug 612728 ***

Note You need to log in before you can comment on or make changes to this bug.