Bug 627358 - [abrt] emacs-ibus-0.1.1-1.fc13: display.py:544:send_and_recv:ConnectionClosedError: Display connection closed by server
Summary: [abrt] emacs-ibus-0.1.1-1.fc13: display.py:544:send_and_recv:ConnectionClosed...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs-ibus
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daiki Ueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:af1f239e
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-25 19:44 UTC by Weonjong Lee
Modified: 2013-02-01 15:21 UTC (History)
4 users (show)

Fixed In Version: emacs-ibus-0.2.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-13 21:59:50 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.28 KB, text/plain)
2010-08-25 19:44 UTC, Weonjong Lee
no flags Details

Description Weonjong Lee 2010-08-25 19:44:04 UTC
abrt version: 1.1.13
architecture: x86_64
cmdline: /usr/bin/python /usr/libexec/ibus-el-agent
component: emacs-ibus
executable: /usr/libexec/ibus-el-agent
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: emacs-ibus-0.1.1-1.fc13
reason: display.py:544:send_and_recv:ConnectionClosedError: Display connection closed by server
release: Fedora release 13 (Goddard)
time: 1282723408
uid: 500

backtrace
-----
display.py:544:send_and_recv:ConnectionClosedError: Display connection closed by server

Traceback (most recent call last):
  File "/usr/libexec/ibus-el-agent", line 73, in <module>
    display = Xlib.display.Display()
  File "/usr/lib/python2.6/site-packages/Xlib/display.py", line 83, in __init__
    self.display = _BaseDisplay(display)
  File "/usr/lib/python2.6/site-packages/Xlib/display.py", line 65, in __init__
    apply(protocol.display.Display.__init__, (self, ) + args, keys)
  File "/usr/lib/python2.6/site-packages/Xlib/protocol/display.py", line 116, in __init__
    auth_prot_data = auth_data)
  File "/usr/lib/python2.6/site-packages/Xlib/protocol/display.py", line 982, in __init__
    display.send_and_recv(request = -1)
  File "/usr/lib/python2.6/site-packages/Xlib/protocol/display.py", line 544, in send_and_recv
    raise self.socket_error
ConnectionClosedError: Display connection closed by server

Local variables in innermost frame:
sending: 0
gotreq: 0
bytes_recv: ''
rs: [<socket._socketobject object at 0x2207210>]
i: 48
self: <Xlib.display._BaseDisplay instance at 0x21fe050>
req: <Xlib.protocol.display.ConnectionSetupRequest instance at 0x21fe6c8>
request: -1
flush_bytes: None
recieving: 1
ws: []
timeout: None
flush: None
wait: 1
recv: None
event: None
es: []
writeset: []

Comment 1 Weonjong Lee 2010-08-25 19:44:06 UTC
Created an attachment (id=441035)
File: backtrace

Comment 2 Daiki Ueno 2010-08-28 05:37:35 UTC
Well I can't reproduce this, at least on GNOME desktop.  Could you provide more information to reproduce this bug, or is it not easy to reproduce?

BTW, the ibus.el developer pointed out that there are similar bugs reported to python-xlib:
https://bugzilla.redhat.com/buglist.cgi?component=python-xlib&product=Fedora
So it might be a bug of python-xlib.

Comment 3 IRIE Shinsuke 2010-10-09 09:04:47 UTC
I modified ibus-el-agent in upstream version (r151) so that it attempts twice to connect to the display if the first goes wrong.

However, I don't know whether the issue is resolved by this change because I cannot reproduce the problem.

Thanks.

Comment 4 Daiki Ueno 2010-11-04 00:52:42 UTC
I'm going to close this with a new package based on the new upstream release 0.2.1.  If it is not the case, please reopen.

Comment 5 Fedora Update System 2010-11-04 01:11:21 UTC
emacs-ibus-0.2.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/emacs-ibus-0.2.1-1.fc14

Comment 6 Fedora Update System 2010-11-04 01:11:31 UTC
emacs-ibus-0.2.1-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/emacs-ibus-0.2.1-1.fc13

Comment 7 Fedora Update System 2010-11-04 23:32:55 UTC
emacs-ibus-0.2.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update emacs-ibus'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/emacs-ibus-0.2.1-1.fc13

Comment 8 Fedora Update System 2010-11-13 21:59:45 UTC
emacs-ibus-0.2.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-11-13 22:01:21 UTC
emacs-ibus-0.2.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.