Bug 627365 - Enable Networking and Enable Wireless options are grayed out in NetworkManager Applet after update
Summary: Enable Networking and Enable Wireless options are grayed out in NetworkManage...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 627025 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-25 20:13 UTC by Michael
Modified: 2018-11-26 17:18 UTC (History)
15 users (show)

(edit)
Clone Of:
: 633501 (view as bug list)
(edit)
Last Closed: 2010-09-08 02:27:52 UTC


Attachments (Terms of Use)

Description Michael 2010-08-25 20:13:40 UTC
Description of problem:
Aug 25 23:29:03 ao yum[2163]: Updated: 1:NetworkManager-0.8.1-3.git20100813.fc12.i686
After this update Enable Networking and Enable Wireless options are grayed out in NetworkManager Applet.

Version-Release number of selected component (if applicable):
1:NetworkManager-0.8.1-3.git20100813.fc12.i686

Comment 1 Eric Work 2010-08-26 18:43:22 UTC
I'm seeing the same problem after the 0.8.1-4 update on F13.

Comment 2 Bruce Brackbill 2010-08-27 02:38:55 UTC
I see this too.

A kind of workaround is to edit the connection.  It will bring up a dialog for root privileges and then the Enable Networking and Enable Wireless will be available.

Has editing a connection always required root? I don't remember it being this way. Maybe this grayed out problem is a privileges issue.

Comment 3 Phil Barnes 2010-08-27 15:53:56 UTC
This bug also prevents use of Mobile Broadband, as Enable Mobile Broadband always starts un-ticked when the device is connected. 
This should make it a more urgent bug. It is rare to need to un-tick Enable Networking or Enable Wireless, but without ticking 'Enable Mobile Broadband' it is impossible to connect. 

Edit connection does not require root privilege, however running something that does (such as system-config-firewall) will make Enable Networking and Enable Wireless available.

Comment 4 Jirka Klimes 2010-08-30 12:38:36 UTC
The 'Enable Wireless', 'Enable Networking' and other properties are protected with policy kit to prevent unauthorized usage (e.g. disabling network by non-local user). These permissions are defined in /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy file.

However, nm-applet didn't set initial permissions and thus the menu items get grayed out.

Fixed upstream:
1aeb178397dd16316bfc242a2e41c54e28933f9a (master)
c7b531250e7417cf51d088c21f91e4a6ef410ac3 (NMA_0_8)

Note:
As a workaround, you can do:
sudo touch /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy
which will update permissions and sensitize the menu items.

Comment 5 Jirka Klimes 2010-08-30 13:32:06 UTC
*** Bug 627025 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2010-09-01 01:25:40 UTC
NetworkManager-0.8.1-6.git20100831.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.1-6.git20100831.fc13

Comment 7 Fedora Update System 2010-09-01 01:40:25 UTC
NetworkManager-0.8.1-6.git20100831.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.1-6.git20100831.fc14

Comment 8 Fedora Update System 2010-09-01 01:42:42 UTC
NetworkManager-0.8.1-6.git20100831.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.1-6.git20100831.fc12

Comment 9 Fedora Update System 2010-09-02 20:47:54 UTC
NetworkManager-0.8.1-6.git20100831.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/NetworkManager-0.8.1-6.git20100831.fc13

Comment 10 Raphael Groner 2010-09-06 17:32:43 UTC
Here is some kind of work around the problem. My idea is to restart the NetworkManager service every time when the system wakes up from hibernation.

Create a file called /etc/pm/sleep.d/50custom with the following content and mark it executable.

A big thanks a lot goes to Khaytsus from IRC who nicely provided this script.

-- start of script
#!/bin/bash

service="/sbin/service"
rm="/bin/rm"
touch="/bin/touch"

case "$1" in
	hibernate)
		$touch /tmp/.hibernate
		;;
	thaw|resume) 
		if [ -e /tmp/.hibernate ]; then
			$rm /tmp/.hibernate
			# do whatever here, $service NetworkManager restart ?
			$service NetworkManager restart
		fi
		;;
	*)
		;;
esac

exit $?
-- end of script

Comment 11 Taunus 2010-09-07 18:38:28 UTC
Installed NetworkManager-0.8.1-6.git20100831.fc13.i686 and dependencies

It is no longer grayed out.

Comment 12 Fedora Update System 2010-09-08 02:27:44 UTC
NetworkManager-0.8.1-6.git20100831.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Raphael Groner 2010-09-10 14:20:53 UTC
Sorry, but it does not seem to work properly. Either Network-Manager is very slow in detecting another network connection being available after an hibernation or the bug is only fixed at half. I had to restart the service to get NM working again (disabled network after waked up from hibernation).

Comment 14 Andrew Haley 2010-09-10 15:22:14 UTC
Raphael, that's a different bug:

https://bugzilla.redhat.com/show_bug.cgi?id=628309

Comment 15 Raphael Groner 2010-09-10 15:44:12 UTC
(In reply to comment #14)
Sorry, but I doubt that it has anything to do with udev. As stated before, the issue is gone if NM is restarted (and nothing else done additionally).

Comment 16 Fedora Update System 2010-09-11 03:34:43 UTC
NetworkManager-0.8.1-6.git20100831.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Andrew Haley 2010-09-11 18:39:59 UTC
(In reply to comment #15)

> Sorry, but I doubt that it has anything to do with udev.

It certainly seems to be.

> As stated before, the
> issue is gone if NM is restarted (and nothing else done additionally).

That's the same symptom as 628309.  By all means tell me I'm wrong, but not if you haven't tried it.

Comment 18 Dimitar Pashev 2010-09-12 13:23:24 UTC
I have same problem on Asus Eeepc 1000h 
NetworkManager-0.8.1-6.git20100831.fc13.i686 is installed.

Аfter executing command :
exec dbus-send --system                        \
        --dest=org.freedesktop.NetworkManager \
        /org/freedesktop/NetworkManager       \
        org.freedesktop.NetworkManager.wake

, the network begins to operate normally

Comment 19 Dan Williams 2010-09-13 13:59:07 UTC
(In reply to comment #18)
> I have same problem on Asus Eeepc 1000h 
> NetworkManager-0.8.1-6.git20100831.fc13.i686 is installed.
> 
> Аfter executing command :
> exec dbus-send --system                        \
>         --dest=org.freedesktop.NetworkManager \
>         /org/freedesktop/NetworkManager       \
>         org.freedesktop.NetworkManager.wake
> 
> , the network begins to operate normally

This issue is different than the issue this bug was filed for and is related to suspend/resume.

Comment 20 Fedora Update System 2010-09-26 04:34:17 UTC
NetworkManager-0.8.1-6.git20100831.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Michael 2010-09-28 03:18:40 UTC
In F12 it's Ok now and it works well just as before the bug.

Comment 22 murenti 2011-01-07 00:50:48 UTC
I am a NOOB and would be very grateful for some easy help to fix this issue, my wireless is greyed out in the network manager and I am having trouble following how to fix this.  I am grateful for anyones help.

Comment 23 murenti 2011-01-07 01:09:12 UTC
I am a NOOB and would be very grateful for some easy help to fix this issue, my wireless is greyed out in the network manager and I am having trouble following how to fix this.  I am grateful for anyones help.


Note You need to log in before you can comment on or make changes to this bug.