Bug 627398 - segfault when running python-jinja2 test suite on big-endian 64-bit architectures
segfault when running python-jinja2 test suite on big-endian 64-bit architect...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-jinja2 (Show other bugs)
6.1
s390x Linux
low Severity medium
: rc
: ---
Assigned To: Python Maintainers
BaseOS QE - Apps
:
Depends On: 627347
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-25 19:13 EDT by Dave Malcolm
Modified: 2016-07-25 11:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 627347
Environment:
Last Closed: 2016-07-25 11:00:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-08-25 19:13:25 EDT
+++ This bug was initially created as a clone of Bug #627347 +++

Python segfaults when running python-jinja2 test suite - see http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=198496 for the logs.

Version-Release number of selected component (if applicable):
python-2.7-7.fc14.s390x


Summarizing that bug: there's an underlying bug in python's object.__basicsize__ which causes Jinja2's usage of ctypes to go badly wrong, and to corrupt the objects within the python process.

The given ctypes code was also present in the python-jinja2-2.2.1-1.3 that was at one time in RHEL6.  Looks like the specfile didn't run %check

Filing this to doublecheck if this is still in RHEL6.  We could work around this in jinja if it is, or fix the bug in python.
Comment 1 RHEL Product and Program Management 2011-01-07 10:57:14 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Note You need to log in before you can comment on or make changes to this bug.