Bug 627408 - Cannot 'verify and boot' without entering pass phrase for encrypted luks partitions
Summary: Cannot 'verify and boot' without entering pass phrase for encrypted luks part...
Keywords:
Status: CLOSED DUPLICATE of bug 589778
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-25 23:30 UTC by Gautam Ghare
Modified: 2013-01-10 06:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-26 17:38:55 UTC
Type: ---


Attachments (Terms of Use)

Description Gautam Ghare 2010-08-25 23:30:49 UTC
Description of problem:
When option 2 "verify and boot" is selected with the Live CD; the boot sequence attempts to mount luks encrypted partitions on the HDD. Selecting the first option allows booting without mounting encrypted partitions.

The user may want to delete the luks encrypted partitions and recreate new ones (with a new key) on a fresh install; and this should be possible without entering the correct pass phrase.

Version-Release number of selected component (if applicable):
14-alpha

How reproducible:
always

Steps to Reproduce:
1. Have at least one luks encrypted partition on the HDD
2. Select option 2: Verify and boot on the Live CD boot menu
3.
  
Actual results:
Boot process requires entering a correct pass phrase for the encrypted partition

Expected results:
Allow booting (and possibly deleting of an encrypted partition) without entering a pass phrase

Additional info:

Comment 1 Matthias Clasen 2010-09-03 17:02:12 UTC
Not sure where this bug needs to go, but LiveCD is not the right component for it.

Comment 2 Charles R. Anderson 2010-11-28 15:16:22 UTC
Where do the syslinux.cfg paramaters for the LiveCD boot come from?  The Verify and Boot option needs to have the same rd_NO_LUKS etc. parameters as the regular boot has.  This problem still exists in F15/rawhide as of 2010-11-25.

Comment 3 Brian Lane 2011-01-26 17:38:55 UTC

*** This bug has been marked as a duplicate of bug 589778 ***


Note You need to log in before you can comment on or make changes to this bug.