Bug 627696 - auto-update-debuginfo plugin does too much work
auto-update-debuginfo plugin does too much work
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-26 13:24 EDT by Adam Jackson
Modified: 2014-01-21 18:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-07 17:27:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Jackson 2010-08-26 13:24:31 EDT
Description of problem:

If I say "yum info libbsd", I get to sit and wait for a few minutes to find out that I have 94 debuginfo packages installed.

This seems to be much worse (in the sense of slower) on my F12 machine than F13, but it's counting either way.

Version-Release number of selected component (if applicable):

yum-utils-1.1.26-1.fc12
yum-utils-1.1.28-1.fc13
Comment 1 Adam Jackson 2010-08-26 13:32:55 EDT
also:

yum-3.2.27-3.fc12
yum-3.2.27-21.fc14

Apparently I was comparing F12 to F14; sorry about the confusion.
Comment 2 James Antill 2010-09-07 17:27:13 EDT
I know "libbsd" isn't in any debuginfo repos., you know that ... yum, not so much :)

Off hand I can't think of how we can make this better. One problem you may be hitting is if you have some PK thing auto-updating all your repo. data (like yum-updatesd used to do), then you might be getting burnt by:

% fgrep auto-up /etc/PackageKit/Yum.conf
# default=rpm-warm-cache;remove-with-leaves;auto-update-debuginfo
DisabledPlugins=rpm-warm-cache;remove-with-leaves;auto-update-debuginfo

...feel free to ask PK to fix their code instead of just disabling random plugins. You can also just run yum-updatesd, just to get the MD (or yum-cron) ... we'll probably eventually change yum-updatesd and/or make a cyum-updated, to do everything but the dbus stuff.

We've done a few speed improvements to yum between the above fc12 and fc14 versions, but I can't think of anything that would speed this up.

Sorry I couldn't be more help.

Note You need to log in before you can comment on or make changes to this bug.