Bug 62779 - RFE: GUI tool(s) for groups
RFE: GUI tool(s) for groups
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
7.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-05 10:13 EST by Baku
Modified: 2013-07-02 18:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 10:39:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Baku 2002-04-05 10:13:20 EST
The usermode package provides utilities for editing nearly all aspects of a 
*user* account. However, "advanced" *group* features are not supported.

In an effort to reduce sysadmin involvement in day-to-day "ownership" problems, 
it would be nice to enable the full gamut of group management features, 
specifically:

 * Assigning group administrators
 * Assigning "newgrp" passwords
 * Allowing group admins to add/remove users
 * Allowing users to "newgrp" from GNOME

To that end, I'd like to ask for:

* User Manager should have controls to assign administrative rights (for a 
group) to specific user(s), assign group passwords, and related fields in the 
GUI.

* Perhaps a separate tool? for users to launch to manage the groups for which 
they are the assigned administrator.

* Ideally, it would be VERY NICE (but probably a logistic nightmare) to 
allow "newgrp" from GNOME. (Probably would require taking this up on the GNOME 
lists, and require a very complex passing-around of the newgrp functionality to 
the Panel, Nautilus, GSM, &c.; i.e. "I've said it" but not worth bothering with 
for a relatively rare case.)
Comment 1 Jindrich Novy 2005-04-07 10:39:42 EDT
This is not really an usermode bug (or better to say RFE), this looks like
something to report to system-config-users package instead.

I'm closing this bug as NOTABUG. Please file a new bug to system-config-users if
you still have some requests for enhancements.

Thanks,
Jindrich

Note You need to log in before you can comment on or make changes to this bug.