Bug 627793 - SELinux is preventing /bin/bash "execute" access on /bin/mountpoint.
Summary: SELinux is preventing /bin/bash "execute" access on /bin/mountpoint.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:e26afa6c9d3...
: 627792 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-27 01:12 UTC by Flóki Pálsson
Modified: 2010-09-21 05:03 UTC (History)
4 users (show)

Fixed In Version: selinux-policy-3.9.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-08 04:31:23 UTC


Attachments (Terms of Use)

Description Flóki Pálsson 2010-08-27 01:12:11 UTC
Summary:

SELinux is preventing /bin/bash "execute" access on /bin/mountpoint.

Detailed Description:

SELinux denied access requested by dhclient-script. It is not expected that this
access is required by dhclient-script and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023
Target Context                system_u:object_r:mount_exec_t:s0
Target Objects                /bin/mountpoint [ file ]
Source                        dhclient-script
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.1.7-3.fc14
Target RPM Packages           sysvinit-tools-2.87-4.dsf.fc14
Policy RPM                    selinux-policy-3.8.8-20.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35.2-9.fc14.x86_64 #1 SMP Tue Aug
                              17 22:36:15 UTC 2010 x86_64 x86_64
Alert Count                   12
First Seen                    fim 26.ágú 2010, 22:31:15 GMT
Last Seen                     fös 27.ágú 2010, 01:08:36 GMT
Local ID                      7d7af239-0fe9-4906-a92e-14c642cec9ca
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1282871316.428:135): avc:  denied  { execute } for  pid=1971 comm="dhclient-script" name="mountpoint" dev=sdb5 ino=659292 scontext=unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mount_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1282871316.428:135): arch=c000003e syscall=59 success=no exit=-13 a0=1516730 a1=14b51c0 a2=1516f40 a3=7fffcdc247b0 items=0 ppid=1965 pid=1971 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=3 comm="dhclient-script" exe="/bin/bash" subj=unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,dhclient-script,dhcpc_t,mount_exec_t,file,execute
audit2allow suggests:

#============= dhcpc_t ==============
allow dhcpc_t mount_exec_t:file execute;

Comment 1 Miroslav Grepl 2010-08-27 10:44:01 UTC
*** Bug 627792 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2010-08-27 11:26:14 UTC
Not sure why dhclient-script is trying to execute mountpoint.

You can execute

chcon -t bin_t /bin/mountpoint

Comment 3 Daniel Walsh 2010-08-27 14:40:29 UTC
Fixed in selinux-policy-3.9.0-1.fc14

Comment 4 Fedora Update System 2010-08-30 15:58:49 UTC
selinux-policy-3.9.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.0-2.fc14

Comment 5 Fedora Update System 2010-08-30 19:37:31 UTC
selinux-policy-3.9.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/selinux-policy-3.9.0-2.fc14

Comment 6 Fedora Update System 2010-09-08 04:29:41 UTC
selinux-policy-3.9.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Jon Masters 2010-09-16 14:40:09 UTC
And rawhide? What's the situation there? I'm still seeing this problem.

Comment 8 Daniel Walsh 2010-09-16 15:53:01 UTC
What policy do you have on rawhide?  What is the label on /bin/mountpoint

ls -lZ /bin/mountpoint

I am trying to keep policy the same on F14 and Rawhide.

Comment 9 Jon Masters 2010-09-17 04:03:07 UTC
-rwxr-xr-x. root root system_u:object_r:bin_t:s0       /bin/mountpoint

Still getting audit logs on this though.

Comment 10 Jon Masters 2010-09-17 04:04:46 UTC
Oh, and I am using the "target" policy with this version:

selinux-policy-targeted-3.9.4-2.fc15.noarch

Comment 11 Jon Masters 2010-09-17 04:05:34 UTC
It's possible it was a stale alert. I reset the context on that mountpoint executable, so let's see if it occurs again tomorrow.

Comment 12 Jon Masters 2010-09-21 05:03:33 UTC
Doesn't seem to be re-occuring any more. Thanks.


Note You need to log in before you can comment on or make changes to this bug.