Bug 627879 - SELinux is preventing /sbin/dmsetup "associate" access .
Summary: SELinux is preventing /sbin/dmsetup "associate" access .
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:2c3e10e8d8c...
: 627885 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-27 09:35 UTC by Nils Philippsen
Modified: 2010-09-08 04:31 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-3.9.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-08 04:31:31 UTC


Attachments (Terms of Use)

Description Nils Philippsen 2010-08-27 09:35:34 UTC
Summary:

SELinux is preventing /sbin/dmsetup "associate" access .

Detailed Description:

[dmsetup has a permissive type (lvm_t). This access was not denied.]

SELinux denied access requested by dmsetup. It is not expected that this access
is required by dmsetup and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:lvm_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                None [ sem ]
Source                        dmsetup
Source Path                   /sbin/dmsetup
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           device-mapper-1.02.54-1.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.8.8-20.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35.2-9.fc14.x86_64 #1 SMP Tue
                              Aug 17 22:36:15 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Fri 27 Aug 2010 11:34:33 AM CEST
Last Seen                     Fri 27 Aug 2010 11:34:33 AM CEST
Local ID                      5e6a44e7-d772-4360-b28a-7e471459155b
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1282901673.79:175): avc:  denied  { associate } for  pid=4058 comm="dmsetup" key=223159837  scontext=system_u:system_r:lvm_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=sem

node=(removed) type=SYSCALL msg=audit(1282901673.79:175): arch=c000003e syscall=64 success=yes exit=720903 a0=d4d261d a1=1 a2=0 a3=1 items=0 ppid=1987 pid=4058 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="dmsetup" exe="/sbin/dmsetup" subj=system_u:system_r:lvm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,dmsetup,lvm_t,unconfined_t,sem,associate
audit2allow suggests:

#============= lvm_t ==============
allow lvm_t unconfined_t:sem associate;

Comment 1 Nils Philippsen 2010-08-27 09:38:29 UTC
When this happened, I was unlocking an encrypted LV:

cryptsetup luksOpen /dev/<VG>/<encrypted LV> <unlocked mapper name>

Comment 2 Daniel Walsh 2010-08-27 15:22:08 UTC
Thanks, I switched lvm_t to a permissive domain, normally unconfined.  So this access was actually allows.


Fixed in selinux-policy-3.9.0-2.fc14

Comment 3 Daniel Walsh 2010-08-27 15:22:54 UTC
*** Bug 627885 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2010-08-30 15:58:58 UTC
selinux-policy-3.9.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.0-2.fc14

Comment 5 Fedora Update System 2010-08-30 19:37:40 UTC
selinux-policy-3.9.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/selinux-policy-3.9.0-2.fc14

Comment 6 Fedora Update System 2010-09-08 04:29:51 UTC
selinux-policy-3.9.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.