Bug 627901 - Segfault when decoding DMI data in dmi_processor_id()
Segfault when decoding DMI data in dmi_processor_id()
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-dmidecode (Show other bugs)
6.1
All Linux
urgent Severity high
: rc
: ---
Assigned To: Roman Rakus
qe-baseos-daemons
: ZStream
Depends On:
Blocks: 726613 726614
  Show dependency treegraph
 
Reported: 2010-08-27 06:56 EDT by Roman Rakus
Modified: 2014-01-12 19:12 EST (History)
15 users (show)

See Also:
Fixed In Version: python-dmidecode-3.10.13-1.el6
Doc Type: Bug Fix
Doc Text:
Previously, certain DMI (Direct Media Interface) tables did not report CPU information as a string and returned the NULL value instead. Consequently, Python terminated unexpectedly with a segmentation fault when trying to identify the CPU type by performing a string comparison. With this update, additional checks for NULL values, performed prior the string comparison, have been added to the code, thus fixing this bug.
Story Points: ---
Clone Of: 596264
Environment:
Last Closed: 2011-12-06 06:51:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Roman Rakus 2011-06-29 12:33:56 EDT
Fixed in python-dmidecode-3.10.13-1.el6
Comment 4 Roman Rakus 2011-07-07 08:19:56 EDT
Proposed for z-streams based on request from Matthew Whitehead
Comment 6 Eliska Slobodova 2011-07-25 10:58:45 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When trying to identify the processor type by performing a string comparison, Python terminated with a segmentation fault. This was caused by DMI tables which did not report the CPU processor information as a string and returned a NULL value instead. This update adds additional checks for NULL values before doing the string comparison.
Comment 9 Tomas Capek 2011-08-03 10:56:37 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-When trying to identify the processor type by performing a string comparison, Python terminated with a segmentation fault. This was caused by DMI tables which did not report the CPU processor information as a string and returned a NULL value instead. This update adds additional checks for NULL values before doing the string comparison.+Previously, certain DMI (Direct Media Interface) tables did not report CPU information as a string and returned the NULL value instead. Consequently, Python terminated unexpectedly with a segmentation fault when trying to identify the CPU type by performing a string comparison. With this update, additional checks for NULL values, performed prior the string comparison, have been added to the code, thus fixing this bug.
Comment 10 David Sommerseth 2011-08-03 11:14:25 EDT
(In reply to comment #9)
>     Technical note updated. If any revisions are required, please edit the
> "Technical Notes" field
>     accordingly. All revisions will be proofread by the Engineering Content
> Services team.
> 
>     Diffed Contents:
> @@ -1 +1 @@
> -When trying to identify the processor type by performing a string comparison,
> Python terminated with a segmentation fault. This was caused by DMI tables
> which did not report the CPU processor information as a string and returned a
> NULL value instead. This update adds additional checks for NULL values before
> doing the string comparison.+Previously, certain DMI (Direct Media Interface)
> tables did not report CPU information as a string and returned the NULL value
> instead. Consequently, Python terminated unexpectedly with a segmentation fault
> when trying to identify the CPU type by performing a string comparison. With
> this update, additional checks for NULL values, performed prior the string
> comparison, have been added to the code, thus fixing this bug.


Just a heads up, the DMI abbreviation is wrong.  From the man page of dmidecode:

       dmidecode  is  a tool for dumping a computer's DMI (some say
       SMBIOS) table contents in a human-readable format.
       [...snip...]

       SMBIOS stands for System Management BIOS, while  DMI  stands
       for Desktop Management Interface. Both standards are tightly
       related and developed by the DMTF (Desktop  Management  Task
       Force).
Comment 12 errata-xmlrpc 2011-12-06 06:51:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1589.html

Note You need to log in before you can comment on or make changes to this bug.