Bug 627919 - sblim-gather init script improvement
sblim-gather init script improvement
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sblim-gather (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Vitezslav Crhonek
qe-baseos-daemons
:
Depends On:
Blocks: 633349
  Show dependency treegraph
 
Reported: 2010-08-27 07:52 EDT by Yulia Kopkova
Modified: 2011-12-06 06:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the sblim-gather init script exit status codes were incorrect in two scenarios: when restarting a service as a non-privileged user and when passing an invalid argument. This bug has been fixed, and all exit status codes of the sblim-gather init script are now correct.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 06:56:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yulia Kopkova 2010-08-27 07:52:56 EDT
Description of problem:
sblim-gather initscript need to be improved according to "Fedora SysV Initscripts [1]" document.

Version-Release number of selected component (if applicable):
sblim-gather-2.2.1-2.el6

1. Init script should return code "4" if restarting service under
nonprivileged user:
# su testuserqa -c "service gatherer restart"; echo $?
Stopping reposd:                                           [FAILED]
Stopping gatherd:                                          [FAILED]
Starting gatherd:                                          [  OK  ]
touch: cannot touch `/var/lock/subsys/gatherd': Permission denied
Starting reposd:                                           [  OK  ]
touch: cannot touch `/var/lock/subsys/reposd': Permission denied
0
now: 0
expected: 4 

3. init script should return code "2" on passing invalid argument
# service gatherer nonexist ; echo $?
Usage gatherd {start|stop|status|restart|condrestart|reload}
1
now: 1
expected: 2

Additional info:
[1]
https://fedoraproject.org/wiki/Packaging/SysVInitScript#Initscripts_on_the_filesystem
Comment 2 RHEL Product and Program Management 2011-01-07 10:28:46 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 Tomas Capek 2011-07-25 05:09:41 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the sblim-gather init script exit status codes were incorrect in two scenarios: when restarting a service as a non-privileged user and when passing an invalid argument. This bug has been fixed, and all exit status codes of the sblim-gather init script are now correct.
Comment 9 errata-xmlrpc 2011-12-06 06:56:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1593.html

Note You need to log in before you can comment on or make changes to this bug.