Bug 628230 - Unable to sync to mtp device; missing dependencies pymtp and pymad
Summary: Unable to sync to mtp device; missing dependencies pymtp and pymad
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gpodder
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 643199
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-28 20:27 UTC by Boyd
Modified: 2011-02-02 19:29 UTC (History)
2 users (show)

Fixed In Version: python-mygpoclient-1.5-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-02 19:27:15 UTC


Attachments (Terms of Use)

Description Boyd 2010-08-28 20:27:06 UTC
Description of problem:  Unable to sync to mtp device; missing dependencies pymtp and pymad.


Version-Release number of selected component (if applicable):  gpodder 2.7


How reproducible:  Check dependencies.


Steps to Reproduce:
1.  Install gpodder and launch
2.  Click on menu item 'Podcasts' 'Additional Components'
3.
  
Actual results:

Feature                        Status
MTP Device Syncronization      Missing Dependencies


Expected results:


Additional info:
Clicking About Button within the Additional Components box will bring message that:  'Module pymtp not installed'.  In addition pymad also needs to be installed.  When manually installing these packages:
http://downloads.nick125.com/projects/pymtp/pymtp-latest.tar.bz2
wget -q http://spacepants.org/src/pymad/download/pymad-0.6.tar.gz
gpodder is now able to sync to mtp device.

Since most users of podcasts will have a device this would be nice to include in Fedora next release.

Comment 1 Ville-Pekka Vainio 2010-08-28 20:40:37 UTC
Pymad is probably not acceptable in Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=193102
Pymtp just needs someone to package it. I don't use MTP myself anywhere and thus wouldn't be able to debug any possible issues with pymtp, so I haven't packaged it.

Comment 2 Fedora Update System 2011-01-15 22:57:02 UTC
python-mygpoclient-1.5-1.fc14,python-pymtp-0.0.4-1.fc14,gpodder-2.12-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-mygpoclient-1.5-1.fc14,python-pymtp-0.0.4-1.fc14,gpodder-2.12-1.fc14

Comment 3 Fedora Update System 2011-01-15 23:01:12 UTC
python-mygpoclient-1.5-1.fc13,python-pymtp-0.0.4-1.fc13,gpodder-2.12-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/python-mygpoclient-1.5-1.fc13,python-pymtp-0.0.4-1.fc13,gpodder-2.12-1.fc13

Comment 4 Fedora Update System 2011-01-17 20:57:36 UTC
python-mygpoclient-1.5-1.fc13, python-pymtp-0.0.4-1.fc13, gpodder-2.12-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-mygpoclient python-pymtp gpodder'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/python-mygpoclient-1.5-1.fc13,python-pymtp-0.0.4-1.fc13,gpodder-2.12-1.fc13

Comment 5 Fedora Update System 2011-02-02 19:27:06 UTC
python-mygpoclient-1.5-1.fc13, python-pymtp-0.0.4-1.fc13, gpodder-2.12-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2011-02-02 19:29:07 UTC
python-mygpoclient-1.5-1.fc14, python-pymtp-0.0.4-1.fc14, gpodder-2.12-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.