Bug 62829 - Installer experiences read errors on ftp laptop install after format
Installer experiences read errors on ftp laptop install after format
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-05 17:13 EST by Scott Schmit
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 17:22:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Schmit 2002-04-05 17:13:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
I did a ftp laptop install, reformatting my / and swap partitions. I chose to
test for bad blocks on my / partition.
After it finished testing for bad blocks (no errors) and formatting (no errors),
an error in white on black went across the package install screen:
"/usr/bin/python1.5: error while loading shared libraries: /lib/libdl.so.2:
cannot read file data: error 21"

This did *not* abort the installer--it kept going.
In the syslog terminal, the following errors were displayed:
... (more of the <6> errors all the way to the top of the screen)
<6>01:01: rw=0, want=5360, limit=4608
<6>attempt to access beyond end of device
<6>01:01: rw=0, want=5360, limit=4608
<4>Error -3 while decompressing!
<4>c02b08d4(-999040208)->c3e43000(4096)

possibly related, but I'm not sure, on the install log terminal:
* swap attempt of 96M to 192M

prior to this error, I was able to use ls, ps, etc at the bash prompt on tty2.
After this, however, I get:
# ls
ls: permission denied
# ps
ps: permission denied

any other command, no matter where I get it from, doesn't work, except the shell
builtins (such as echo $PATH)
I didn't think to try echo *

As it installed, (which it seemed to do normally without any further error), I
left to go to the grocery store.
When I came back, the installer had crashed: "install exited abnormally --
recieved signal 11...(unmounting, can reboot)"
This was in the middle of some text ui screen, but I couldn't tell what (didn't
think to page up before looking at the syslog screen).
On the syslog screen, I saw more of the <6> and <4> error messages above, but
with different numbers than before or even from one another.

The shell no longer reacted to input, but that's probably because the machine
shut down.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Tell Jeremy Katz to borrow my laptop
2. Have him do an ftp laptop install

Actual Results:
It segfaulted.

Expected Results:
1.) A happy installed system with skipjack beta 2 installed.
2.) An end to That Evil Monopoly.

Of course, I'll settle for just #1.

Additional info:

This also occurred in skipjack beta #1, but it had looked like the bugs were
fixed in CVS so I didn't report it. An ftp install of RHL7.2 from the same
machine (mork.eos.ncsu.edu) onto this machine did not fail.

I haven't (yet) tried to reproduce the bug with beta #2, but considering that
the error doesn't depend on anything already on the machine (stuff gets
formatted), and it's (probably) not the hardware, I think it's safe to assume
it's 100% reproducable. I'm going to try again in a little bit, so if that's not
the case, I'll let you know.

I was able to successfully install beta #1 with an nfs gui install (again, from
mork.eos.ncsu.edu).

If you need any further information, please let me know. Unfortunately, the
installer crashed w/o giving me the opportunity to save anything to disk, so
that's not an option...
Comment 1 Scott Schmit 2002-04-05 17:22:04 EST
Oh yeah, another possibly relevant piece of information:
I booted the installer via grub and dosutils/autoboot/{vmlinuz,initrd.img}. The
grub stanza I used is:
title Skipjack Install
    root (hd0,1) # or whatever /dev/hda2 is in grubspeak
    kernel /tmp/vmlinuz ro root=/dev/hda2
    initrd /tmp/initrd.img
Comment 2 Jeremy Katz 2002-04-05 17:37:53 EST
You didn't add the appropriate 'ramdisk_size=8192' option to the kernel line. 
This is required so the entire second stage can fit in a ramdisk.

Note You need to log in before you can comment on or make changes to this bug.