Bug 62848 - linksys Instant Wireless card does not work with orinoco_cs
linksys Instant Wireless card does not work with orinoco_cs
Product: Red Hat Public Beta
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-04-06 01:01 EST by Seth Vidal
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-09 06:08:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2002-04-06 01:01:55 EST
Description of Problem:
linksys instant wireless card
dump_cis - pertinent info below:
 vers_1 5.0, "Instant Wireless ", " Network PC CARD", "Version 01.02",

the linksys wireless card will not work with the orinoco_cs drivers. It needs
the wvlan_cs drivers to work correctly.

it comes up as an Intersil PRISM2 card

editing /etc/pcmcia/config
and changing the bind entry for:
card "Intersil PRISM2 11 Mbps Wireless Adapter"

to wvlan_cs 
fixes the problem.

Version-Release number of selected component (if applicable):

How Reproducible:

Steps to Reproduce:
1. loadup beta2
2. insert linksys wireless card

Actual Results:
it blinks impolitely at you :)

Expected Results:
it should blink pleasingly as it passes packets.
Comment 1 Konstantin Ryabitsev 2002-04-06 01:06:52 EST
Mine actually worked, but the throughput was very low (15 minutes to download
10Mb file) and my network was saturated with packets -- collisions and all that
fun. Switching to wvlan_cs worked very well.

Also -- same problem exists when installing. The installer tries to load
orinoco_cs but fails. Probably should be fixed there as well.
Comment 2 Warren Togami 2002-04-06 05:19:19 EST
I'm sorry, this one is my fault.  Apparently my SMC2632 802.11b card also 
identifies as Intersil PRISM2, but it absolutely refuses to work with the wvlan 
driver.  Unfortunately it *sorta* works with orinoco_cs albeit with massive 
packet loss.

I also own the SMC2602, which is a SMC2632 card in a PLX PCI adapter.  This 
machine is running with 100% success and zero packet loss with the orinoco_plx 
driver.  wvlan_cs does NOT WORK for my Intersil PRISM2 card, but I guess 
reverting back to wvlan_cs should be done because orinoco_cs isn't a good 
solution for anyone either.

You were running 100% with wvlan_cs on your PRISM2?
Comment 3 Seth Vidal 2002-04-07 01:07:09 EST
Yah. Mine was working great with wvlan_cs.

I think the intersil cards are subtley different despite being mostly the same.

Comment 4 Warren Togami 2002-04-09 06:08:16 EDT
Please revert Intersil Prism2 back to wvlan_cs driver.
Comment 5 Arjan van de Ven 2002-04-09 06:14:49 EDT
agreed; done.

Note You need to log in before you can comment on or make changes to this bug.