Bug 62851 - rp3 is using a non-existant font
Summary: rp3 is using a non-existant font
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2002-04-06 12:15 UTC by Manfred Hollstein
Modified: 2013-04-02 04:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 18:35:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for rp3 using a non-existing font (2.03 KB, patch)
2002-04-06 12:21 UTC, Manfred Hollstein
no flags Details | Diff

Description Manfred Hollstein 2002-04-06 12:15:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
The current version of RP3 is using the font

  -schumacher-clean-medium-r-normal-*-*-80-*-*-c-*-iso8859-1

This font however is called differently since X11R6 - looking at
some comments in /usr/X11R6/lib/X11/fonts/misc/fonts.alias from
an earlier version of this file (e.g. Red Hat Linux 7.1) reveals this:

! These fonts are not really ISO8859-1, but these aliases are provided
! for compatibility with X11R5.

Those aliases have been omitted beginning with RHL 7.2, hence fonts
with such names do not exist anymore.

When the "rp3" exec fails to load this font during startup, it's
issueing a warning message (e.g. in ~/.xsession-errors):

  ** WARNING **: Couldn't load fonts for NETMON display

and falls back to using the font "fixed". With a standard theme and
no fonts changed otherwise (e.g. in ~/.Xdefaults), this looks rather
ugly because "fixed" is simply too large for this small applet! The
attached patch fixes this.


Version-Release number of selected component (if applicable):
redhat-config-network-0.9.21-1


How reproducible:
Always

Steps to Reproduce:
1.Start rp3 as an applect monitoring "eth0"
2.Watch the numbers shown in the applet
3.They are TOO LARGE
	

Actual Results:  The applet looks ugly; most information is lost due to the
numbers being too large.

Expected Results:  A similar layout as has been available as part of RHL 7.1 and
earlier.

Additional info:

Comment 1 Manfred Hollstein 2002-04-06 12:21:34 UTC
Created attachment 52544 [details]
patch for rp3 using a non-existing font

Comment 2 Harald Hoyer 2002-04-10 09:02:27 UTC
fixed in 0.9.23

Comment 3 Trond Eivind Glomsrxd 2002-04-12 00:34:21 UTC
Is this stil a problem with version 0.9.24 at http://people.redhat.com/teg/neat/ ?

Comment 4 Manfred Hollstein 2002-04-12 18:35:02 UTC
Works perfectly now!


Note You need to log in before you can comment on or make changes to this bug.