Bug 62852 - headers from cdparanoia-devel not recognized by kde
Summary: headers from cdparanoia-devel not recognized by kde
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: cdparanoia (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-06 12:41 UTC by Gregorio Guidi
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 13:22:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gregorio Guidi 2002-04-06 12:41:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0; Linux)

Description of problem:
if someone wants to compile kde (2.2.x or 3.0) with cdparanoia support is in trouble, because when running "./configure --with-cdparanoia" of kdebase, it will search for headers in /usr/include while the files are in /usr/include/cdda


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. have cdparanoia-devel-alpha9.8-7 installed
2. within kdebase-3.0 run "./configure --with-cdparanoia"
3.
 

Actual Results:  configure output:

checking for cdparanoia libraries and headers... searched but not found

Expected Results:  configure output:

checking for cdparanoia libraries and headers... incs=/usr/include libs=/usr/lib

Additional info:

Comment 1 Peter Jones 2002-04-15 13:22:03 UTC
There's some confliction between this and bug #38223.  Basicly, we need to ship
utils.h, and I'm not about to drop a file named "utils.h" in /usr/include/ . 
Bero, does our kdebase package have this problem?  If so, can we make it look in
/usr/include/cdda for these headers?

Comment 2 Bernhard Rosenkraenzer 2002-04-15 13:45:41 UTC
Our kdebase package doesn't have the problem (I've patched the configure 
check), and neither does the current CVS tree (I've committed the patch 
upstream a while ago, shortly after the 3.0 release). 



Note You need to log in before you can comment on or make changes to this bug.