Bug 628649 - Freeciv 2.2.2 crash, maybe for stealth fighter issue.
Summary: Freeciv 2.2.2 crash, maybe for stealth fighter issue.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freeciv
Version: 13
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Thomas Janssen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-30 16:09 UTC by addammo
Modified: 2010-09-23 12:37 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-09-17 18:28:50 UTC


Attachments (Terms of Use)
Game saved file. (124.37 KB, application/x-gzip)
2010-08-30 16:09 UTC, addammo
no flags Details
Proposed patch from freeciv authors. (18.10 KB, patch)
2010-08-30 16:13 UTC, addammo
no flags Details | Diff

Description addammo 2010-08-30 16:09:13 UTC
Created attachment 441979 [details]
Game saved file.

Description of problem:

I launch freeciv from terminal and i got this error with crash:

[francesco@localhost ~]$ freeciv-gtk2

(freeciv-gtk2:2779): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(freeciv-gtk2:2779): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(freeciv-gtk2:2779): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
1: 0xfa8c260 2405 Stealth Fighter at (34,53) Charles Martel
1: 0xdfe4e30 3663 Stealth Fighter at (34,53) Charles Martel
freeciv-gtk2: packhand.c:2529: handle_tile_info: Asserzione `unit_list_size(ptile->units) == 0' fallita.
Abortito (core dumped)

Same error with freeciv version 2.2.0 (always under Fedora 13).

I attach the game saved file.


Version-Release number of selected component (if applicable): 2.2.2-1


How reproducible:
just open it to continue the game and push for new turn. It crashes with the above error message.


Steps to Reproduce:
1. Copy the attached file into ~/.freeciv/saves
2. Launch the game and load this file 
3. Just push for next turn. Freeciv crashes.
  
Actual results:


Expected results:


Additional info:

Comment 1 addammo 2010-08-30 16:13:35 UTC
Created attachment 441980 [details]
Proposed patch from freeciv authors.

This is a file patch submitted from the author for testing.
Link: https://gna.org/bugs/index.php?16592

Comment 2 Thomas Janssen 2010-08-30 20:24:05 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=2435926

That's a scratchbuild for you to test it. Thanks btw :)

Comment 3 addammo 2010-08-31 07:14:36 UTC
(In reply to comment #2)
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2435926
> 
> That's a scratchbuild for you to test it. Thanks btw :)

It seems that works for me. Thanks a lot.

Comment 4 addammo 2010-08-31 07:58:43 UTC
(In reply to comment #2)
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2435926
> 
> That's a scratchbuild for you to test it. Thanks btw :)

It seems that works for me. Thanks a lot.

Comment 5 Fedora Update System 2010-08-31 10:34:01 UTC
freeciv-2.2.2-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/freeciv-2.2.2-2.fc14

Comment 6 Fedora Update System 2010-08-31 10:34:06 UTC
freeciv-2.2.2-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/freeciv-2.2.2-2.fc13

Comment 7 Fedora Update System 2010-08-31 20:18:54 UTC
freeciv-2.2.2-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freeciv'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/freeciv-2.2.2-2.fc14

Comment 8 Fedora Update System 2010-09-17 18:28:45 UTC
freeciv-2.2.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-09-23 12:37:38 UTC
freeciv-2.2.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.