Bug 62866 - Installer crashes while installing packages
Installer crashes while installing packages
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-06 14:40 EST by Dylan P
Modified: 2008-01-17 12:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dylan P 2002-04-06 14:40:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4.1) Gecko/20020314
Netscape6/6.2.2

Description of problem:
Testing the first three cd's at the beginning only the second disk passes. I
re-burnced the first and third cd and got the same result. Never have I had
trouble burning the cd's before. I tried them anyway and the installer crashes
after 5 minutes of installing packages. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Burn cd's
2.Install
3.
	

Actual Results:  Crashes

Expected Results:  Continues with install

Additional info:

The crashes occured while installing netscape and the second time during OMNI or
something like that.
Comment 1 Warren Togami 2002-04-08 04:44:15 EDT
Have you checked the MD5SUMs of the images before burning? 
 
Does the installer of Red Hat 7.2 or any other Linux distribution work 
properly on this computer?
Comment 2 matthew 2002-04-09 12:01:12 EDT
I have not yet tried skipjack beta 2, but with beta 1, I had very similar problems.  

All disks pass the media check test in the beginning of the install process.  I have 
successfully installed skipjack using vmware, but  it fails when installing natively.  It 
hangs *EVERYTIME* during the package install process.  Where it hangs is 
random, just somewhere during the install, usually within the first 100-200Meg. 
My system is an Athlon XP 1600+ with an Asus 266E (Via KT266A chipset) with 
512M DDR, and an nvidia Geforce 2MX.  I also tried another mother board in the 
same system and ECS K7S5a (sis chipset), and the same exact thing happens.  
This is discouraging, since I really want to test the RH73 beta.
Comment 3 matthew 2002-04-09 12:05:28 EDT
Just add a little more detail.  It doesn't crash or reboot, it just hangs.  It looks like it 
still trying to work, but nothing happens.  The harddisk light stays fully on (does not 
blink).   I have left it there for nearly 12 hours just to make sure it wasn't going to 
get past this eventually.  When I check some of the other consoles to see if there 
are any errors being dished out by the installer or the kenel, nothing seems out of 
place.  I can get between the different consoles with not problems, and I can get 
back to the gui installer, it's just that the install no longer continues.
Comment 4 Dylan P 2002-04-09 12:17:52 EDT
I can't make disks that pass the test at the beginning. I even redownloaded the
iso images. I ALWAYS made other disks for every redhat release AND beta. This is
the first time I had trouble.
Comment 5 Michael Fulbright 2002-04-09 12:58:39 EDT
If you look on VC4 and VC5 (cntl-alt-f4 and cntl-alt-f5) when the installer
crashes, are there any error messages about read errors?

Does the installer crash, or simply say it cannot install a particular package?
Comment 6 matthew 2002-04-09 15:18:54 EDT
I guess I was not clear.

The install does nothing except stop working, almost as if the kernel is waiting on 
something to get written to disk, but never does.  I checked VC4 and VC5 and 
there was no error reported.  The installer did not crash, it never reported an error 
ever, it just hangs.  I would think that it's still working if I wasn't waiting 10 hours for 
the same package to install, with zero progress over those ten hours.
Comment 7 Michael Fulbright 2002-04-10 16:31:53 EDT
When it is in this state goto VC2 and type 'ps auxww' and see if there are any
programs running other than alot of processes whose names are in [], like
'[swapper]'.  It could be a script from a package is caught running forever.
Comment 8 Michael Fulbright 2002-05-06 14:27:46 EDT
Closing due to inactivity. Please reopen if there is new information regarding
the issue report.
Comment 9 matthew 2002-05-21 14:32:45 EDT
I am still having this problem (sorry I was out of town for a few weeks and didnot 
follow up before).  I have since this report downloaded and burned the released 
redhat 7.3 isos.  I have done: linux media check, and all the disks check out as 
PASS.

The system still just freezes during the package install phase.  I do a ps auxww 
as requested and the following processes are listed (I am excluding the ones in []):

12 root	S	linuxrc
13 root S	linuxrc
14 root	S	/usr/bin/python1.5 /usr/bin/anaconda -m cdrom://hdc/mnt/source
41 root	S	-/bin/sh
68 root	S	/usr/X11R6/bin/XF86_FBDev -xf86config /tmp/XF86Config.test :1 
vt7 -s 1440	-term
70 root	D	/usr/bin/python1.5 /usr/bin/anaconda -m cdrom://hdc/mnt/source
96 root S	/usr/bin/python1.5 /usr/bin/anaconda --syslogd /mnt/sysimage 
/mnt/sysimage/root
110 root R	ps auxww
Comment 10 Red Hat Bugzilla 2006-02-21 13:48:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.