Bug 628721 - 'VirtualDisk' object has no attribute 'DRIVER_TYPE_AIO'
'VirtualDisk' object has no attribute 'DRIVER_TYPE_AIO'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 636999 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-30 16:22 EDT by Mark Watts
Modified: 2011-04-16 16:58 EDT (History)
10 users (show)

See Also:
Fixed In Version: python-virtinst-0.500.6-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-16 16:55:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for F14 code (638 bytes, text/plain)
2010-12-09 15:14 EST, Cole Robinson
no flags Details

  None (edit)
Description Mark Watts 2010-08-30 16:22:43 EDT
Note: I have both updates-testing and the rawvirt (http://jforbes.fedorapeople.org/virt-preview/f13/$basearch/) repos enabled.

Fully up-to-date as of 30/08/2010

Attempting to install CentOS 5.5 via kickstart in a KVM virtual machine:

NAME=VM_01; virt-install --connect qemu:///system \
	--wait 10 \
	--os-variant=rhel5.4 \
	--os-type=linux \
	--name $NAME \
	--ram 256 \
	--vcpus=1 \
	--disk path=/dev/KVM_Volume/$NAME,bus=virtio \
	--network bridge=br0 \
	--noautoconsole \
	--location http://192.168.1.251/centos/5.5/os/x86_64/ \
	-x "ks=http://192.168.1.251/centos/kickstart/centos-base.ks"

Starting install...
Retrieving file .treeinfo...   |  834 B     00:00 ... 
Retrieving file vmlinuz...     | 3.7 MB     00:00 ... 
Retrieving file initrd.img...  |  15 MB     00:00 ... 
Creating domain...             |    0 B     00:00     
Domain installation still in progress. Waiting 10 minutes for installation to complete.
Domain has shutdown. Continuing.
ERROR    'VirtualDisk' object has no attribute 'DRIVER_TYPE_AIO'

Domain installation does not appear to have been
successful. If it was, you can restart your domain
by running 'virsh start VM_01'; otherwise, please
restart your installation.



Manually starting the VM works as expected.


# rpm -qa | grep virt
libvirt-python-0.8.2-3.fc13.x86_64
virt-viewer-0.2.1-1.fc13.x86_64
libvirt-client-0.8.2-3.fc13.x86_64
virt-manager-0.8.4-3.fc13.noarch
python-virtkey-0.50-6.fc12.x86_64
python-virtinst-0.500.4-1.fc13.noarch
libvirt-0.8.2-3.fc13.x86_6

# uname -a
Linux athlon.linux-corner.info 2.6.33.8-149.fc13.x86_64 #1 SMP Tue Aug 17 22:53:15 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Cole Robinson 2010-09-03 10:35:32 EDT
Thanks for the report, fixed upstream:

http://hg.fedorahosted.org/hg/python-virtinst/rev/8c9af019b3ec
Comment 2 Cole Robinson 2010-10-14 12:14:49 EDT
*** Bug 636999 has been marked as a duplicate of this bug. ***
Comment 3 MikeP 2010-10-23 16:24:18 EDT
if the upstream fix is this one

     1.1 --- a/virtinst/Installer.py	Mon Aug 30 17:01:46 2010 -0400
     1.2 +++ b/virtinst/Installer.py	Mon Aug 30 18:01:15 2010 -0400
     1.3 @@ -342,7 +342,7 @@
     1.4              return True
     1.5  
     1.6          if (disk.driver_type and
     1.7 -            disk.driver_type not in [disk.DRIVER_TYPE_AIO,
     1.8 +            disk.driver_type not in [disk.DRIVER_TYPE_RAW,
     1.9                                       disk.DRIVER_TYPE_QEMU]):
    1.10              # Might be a non-raw format
    1.11              return True

Then it just changes the error to:

ERROR 'VirtualDisk' object has no attribute 'DRIVER_TYPE_RAW'
when installing XP from .iso to a .img target
Comment 4 Cole Robinson 2010-10-27 11:29:13 EDT
Yeah, an additional fix and unit test was committed later:

http://hg.fedorahosted.org/hg/python-virtinst/rev/71cf9a1113c8
Comment 5 MikeP 2010-11-16 11:52:01 EST
Just checked the FC14 Release code and this update is not in 

I have tried the change as above and it certainly work for an XP install either from virt-install or console.

its marked as post so fingers crossed
Comment 6 Charles Butterfield 2010-12-09 15:00:37 EST
I've also run into this problem on F14.  How exactly do I get this update?  Do I need to enable the "updates-testing" repo?
Comment 7 Charles Butterfield 2010-12-09 15:03:56 EST
Sorry, I should have "just done it" - then I would have seen that there is no update.  Is the correct approach to just manually replace the single "Installer.py" file mentioned in Comment 4?
Comment 8 Cole Robinson 2010-12-09 15:14:48 EST
Created attachment 467837 [details]
Patch for F14 code

There isn't an update yet. An interim fix is to download the attachment, then as root run

patch -p2 -d /usr/lib/python2.7/site-packages/virtinst < /path/to/the/downloaded/file.patch

If for some reason that makes thing worse, you can recover with

yum install yum-utils
yumdownloader python-virtinst
rpm -Uvh --force python-virtinst*.rpm

An update is coming soon-ish, I'm just trying to get some work done before I push an upstream release.
Comment 9 Charles Butterfield 2010-12-09 19:03:16 EST
Thanks! I applied the F14 patch (in comment #8) and all is well :-)
Comment 10 Fedora Update System 2011-03-31 10:13:23 EDT
python-virtinst-0.500.6-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-virtinst-0.500.6-1.fc14
Comment 11 Fedora Update System 2011-03-31 10:15:48 EDT
python-virtinst-0.500.4-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/python-virtinst-0.500.4-2.fc13
Comment 12 Fedora Update System 2011-04-01 14:26:29 EDT
Package python-virtinst-0.500.4-2.fc13:
* should fix your issue,
* was pushed to the Fedora 13 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-virtinst-0.500.4-2.fc13'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/python-virtinst-0.500.4-2.fc13
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2011-04-16 16:54:58 EDT
python-virtinst-0.500.4-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2011-04-16 16:58:12 EDT
python-virtinst-0.500.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.