Bug 628849 - Rebase febootstrap in RHEL 6.1
Summary: Rebase febootstrap in RHEL 6.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: febootstrap
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 613593
TreeView+ depends on / blocked
 
Reported: 2010-08-31 08:10 UTC by Richard W.M. Jones
Modified: 2011-11-14 20:21 UTC (History)
3 users (show)

Fixed In Version: febootstrap-2.11-5.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:11:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0587 normal SHIPPED_LIVE febootstrap enhancement update 2011-05-18 17:56:48 UTC

Description Richard W.M. Jones 2010-08-31 08:10:08 UTC
Description of problem:

To support the new ext2/disk-based appliance in rebased libguestfs
(bug 613593) we require febootstrap >= 2.9.

This is a backwards-compatible change over the current version (2.7), which
adds the ability to build ext2-based appliances and fixes a couple of minor
bugs elsewhere.

Comment 2 Richard W.M. Jones 2010-08-31 08:34:27 UTC
Commits in 2.9 vs 2.7:
http://git.annexia.org/?p=febootstrap.git;a=shortlog;h=2.9

Comment 4 Richard W.M. Jones 2010-11-18 19:51:19 UTC
https://brewweb.devel.redhat.com/taskinfo?taskID=2902498

Comment 5 Richard W.M. Jones 2010-11-26 09:35:04 UTC
Setting back to ASSIGNED.  We found a bug in febootstrap 2.10
yesterday to do with creating large directories.  Fixed upstream
in this commit:
http://git.annexia.org/?p=febootstrap.git;a=commitdiff;h=cf29103041581a1d71444f978ad4f6ad69b63033
We should rebase to 2.11 which includes this fix.

Comment 6 Richard W.M. Jones 2010-11-29 20:27:08 UTC
https://brewweb.devel.redhat.com/buildinfo?buildID=150384

Comment 7 Richard W.M. Jones 2010-12-11 20:38:02 UTC
Setting back to assigned, discovered and fixed another
bug upstream:
http://git.annexia.org/?p=febootstrap.git;a=commitdiff;h=3efcdd7df2b8997e0d4f543703d371e8b7079d5f

Comment 8 Richard W.M. Jones 2010-12-11 20:50:00 UTC
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2968458

Comment 12 Jinxin Zheng 2011-01-28 03:37:16 UTC
libguestfs now requires febootstrap >= 2.11, and we found no regression caused by this rebase. Moving to VERIFIED.

Comment 13 errata-xmlrpc 2011-05-19 13:11:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0587.html


Note You need to log in before you can comment on or make changes to this bug.