Bug 62887 - kickstart install fails with ks=hd:fd0/hostname.ks
kickstart install fails with ks=hd:fd0/hostname.ks
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
Depends On:
Blocks: 61901
  Show dependency treegraph
Reported: 2002-04-07 00:07 EST by Alexandre Oliva
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-09 22:29:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
libero.ks (4.49 KB, text/plain)
2002-04-09 00:24 EDT, Alexandre Oliva
no flags Details

  None (edit)
Description Alexandre Oliva 2002-04-07 00:07:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
If I create a floppy disk containing a kickstart file, but name the file
something other than ks.cfg, kickstart will fail to use it.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.create a trivial kickstart file
2.copy it to the disk with the name foo.ks
3.boot from the bootnet floppy with `linux ks=hd:fd0/foo.ks dd'
4.load the driver disk


Actual Results:  Error opening: kickstart file /tmp/ks.cfg: No such file or

If I omit the `dd', it doesn't report any error, and just proceeds to asking the
installation language.

Expected Results:  It would be nice if it would just work.

Additional info:
Comment 1 Jeremy Katz 2002-04-08 18:46:55 EDT
This just worked for me with a kickstart config named ks.foo and booting with
'linux ks=hd:fd0/ks.foo'.  Are there any error messages listed on tty3?
Comment 2 Alexandre Oliva 2002-04-08 23:27:47 EDT
Hmm...  Perhaps there is only a problem in the case of the `dd'.

This was booting off a bootnet.img floppy, btw.

I didn't have virtual consoles at such an early stage to tell whether there were
any messages there.

Anyway, I'm confused as to why kickstart installation didn't work when I didn't
use the driver disk.  Perhaps it had trouble with network detection (it's an
rtl8139 card, whose driver is not present in bootnet.img) and fell back to
manual installation?
Comment 3 Jeremy Katz 2002-04-09 00:02:46 EDT
8139too is actually on bootnet, so you shouldn't need a driver disk.  What did
the kickstart config look like (mine didn't get to stage 2, but that's just
because I specified a non-existent NFS path for it to mount :-)

And you should have the different VCs at that point to look and get more
information, tty3 just tends to scroll fast early :/
Comment 4 Alexandre Oliva 2002-04-09 00:22:50 EDT
Hmm...  I don't see it in modules.cgz in the initrd.img in bootnet.img. 
Curiously, mii.o is there, but 8139too depends on mii.o and, when the driver
disk is loaded, is says it loads the mii module.

Anyway, without the driver disk I could not get it to recognize the rtl8139 card
and, as soon as I had the driver disk in, it worked fine.

I'll attach the config file.
Comment 5 Alexandre Oliva 2002-04-09 00:24:38 EDT
Created attachment 52809 [details]
Comment 6 Jeremy Katz 2002-04-09 19:48:41 EDT
Oops, moved 8139too back to bootnet.  Somehow had a couple of drivers migrate. 
I'll look into the other part shortly.
Comment 7 Jeremy Katz 2002-04-09 19:56:47 EDT
Aha, I bet I know what's going on -- do you have the kickstart config on the
boot floppy or the driver disk?  The kickstart config is loaded after the driver
disk, so it would need to be on the latter.
Comment 8 Alexandre Oliva 2002-04-09 20:51:35 EDT
Tried that too, it didn't help.

But having the kickstart file in the boot floppy works, as long as it is named
ks.cfg.  There's probably some code supposed to save a copy of it in /tmp, but
such code fails to take other names into account.  I'd also guess it won't work
if I try kickstart includes.
Comment 9 Jeremy Katz 2002-04-09 22:29:28 EDT
%pre gets processed long after driver disks (it's not done until we get stage 2
loaded), so has very little effect for %include. 

I just did a test with the older tree where 8139too isn't on bootnet with 'linux
dd ks=hd:fd0/ks.foo' and had it work properly loading the kickstart config off
of the driver disk.  Which, although a little odd, is correct as far as its
always been.  Were there any messages on tty3 about being unable to copy the file?
Comment 10 Alexandre Oliva 2002-04-09 23:19:26 EDT
Hmm...  It worked this time.  How odd...
I was even more surprised because I couldn't find the kickstart file in the
drivers disk.  Perhaps I goofed and failed to unmount /mnt/floppy before
removing it?  I can't promise this didn't happen, unfortunately :-(

Oh, well...  At least I'm now happy cause I won't need the drivers disk for
final :-)

Sorry about the noise :-(

Note You need to log in before you can comment on or make changes to this bug.