Bug 628909 - [abrt] unixODBC-2.2.14-11.fc12: main: Process /usr/bin/isql was killed by signal 11 (SIGSEGV)
Summary: [abrt] unixODBC-2.2.14-11.fc12: main: Process /usr/bin/isql was killed by sig...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: unixODBC
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c957f6414e4f51ac991f3fdaa56...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-31 11:23 UTC by Pavel Slama
Modified: 2013-07-03 03:32 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-09-09 01:12:25 UTC


Attachments (Terms of Use)
File: backtrace (49.47 KB, text/plain)
2010-08-31 11:23 UTC, Pavel Slama
no flags Details

Description Pavel Slama 2010-08-31 11:23:12 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: isql teiidodbc -b
comment: all works fine on RHEL 5 with unixODBC 2.2.12
component: unixODBC
crash_function: main
executable: /usr/bin/isql
kernel: 2.6.32.19-163.fc12.x86_64
package: unixODBC-2.2.14-11.fc12
rating: 4
reason: Process /usr/bin/isql was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
time: 1283253224
uid: 500

How to reproduce
-----
use isql utility (from unixODBC 2.2.14) with -b param (batch mode) and input redirection, e.g.:

isql DSN -b < query.sql
or
cat query.sql | isql DSN -b
or
echo '<query>' | isql DSN -b

Comment 1 Pavel Slama 2010-08-31 11:23:15 UTC
Created an attachment (id=442156)
File: backtrace

Comment 2 Tom Lane 2010-08-31 17:25:05 UTC
Confirmed here, it's a silly typo.  Looks like upstream already found it, but the fix isn't in 2.2.14 ...

Comment 3 Fedora Update System 2010-08-31 22:19:08 UTC
unixODBC-2.2.14-12.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/unixODBC-2.2.14-12.fc13

Comment 4 Fedora Update System 2010-08-31 22:19:13 UTC
unixODBC-2.2.14-12.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/unixODBC-2.2.14-12.fc12

Comment 5 Fedora Update System 2010-08-31 22:19:18 UTC
unixODBC-2.2.14-12.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/unixODBC-2.2.14-12.fc14

Comment 6 Fedora Update System 2010-09-01 03:27:04 UTC
unixODBC-2.2.14-12.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update unixODBC'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/unixODBC-2.2.14-12.fc12

Comment 7 Pavel Slama 2010-09-01 12:54:58 UTC
The update works fine, thanks..

Comment 8 Fedora Update System 2010-09-09 01:12:21 UTC
unixODBC-2.2.14-12.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-09-09 01:22:27 UTC
unixODBC-2.2.14-12.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-09-09 04:30:51 UTC
unixODBC-2.2.14-12.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.