Bug 62898 - no sound in kde
no sound in kde
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
Depends On:
Blocks: 61901
  Show dependency treegraph
Reported: 2002-04-07 08:24 EDT by Gerald Teschl
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-08 15:07:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2002-04-07 08:24:14 EDT
I have no sound in kde.


Sound works on the console.
I can play audio cds with kscd.
I don't get any sound from noatun. If click on the play button
just nothing happens. Similar results if I try to play the
sartup wav file from kontrolcenter.

This is an opl3sax based sound card from yamaha.
Comment 1 Bernhard Rosenkraenzer 2002-04-08 06:51:20 EDT
Is artsd running? 
Does play /usr/share/sounds/KDE_Startup.wav (while in KDE) work? 
Does artsplay /usr/share/sounds/KDE_Startup.wav (while in KDE) work? 
Are you trying to run artsd and esd simultaneously? 
Comment 2 Gerald Teschl 2002-04-09 05:48:01 EDT
Yes, artsd is running.

No, play does not work:
[gerald@soliton bin]$ play /usr/share/sounds/KDE_Startup.wav
sox: Can't open output file '/dev/dsp': Device or resource busy

No, artsplay does not work either:
[gerald@soliton bin]$ artsplay /usr/share/sounds/KDE_Startup.wav
[gerald@soliton bin]$ echo $?

No, I am not running esd
Comment 3 Bill Nottingham 2002-04-09 17:05:17 EDT
Do sounds work at all outside of KDE (i.e., does this appear to be a driver issue?)
Comment 4 Gerald Teschl 2002-04-10 04:16:49 EDT
There are some problems with the sound card (I have to set it up manually,
see #60951) but

play /usr/share/sounds/KDE_Startup.wav

works right after setting up the card. However, once artsd has been started,
the sound card does no longer work (even if I stop arts) and I have to reboot
(if I unload the module and then try to reload it I get "No such device" from

I also tried the old kernel from 7.2 (sound works fine under 7.2) but with
the same result.

PS: Is it intentional that I cannot see #61901?
Comment 5 R P Herrold 2002-04-30 02:45:10 EDT
Same versioning, through up2date.  I am gerring this error as well.  I can start
and play both in console mode, and X in a console winodw using:
  mpg123 Alison\ Krauss\ and\ Dolly\ Parton\ -\ Just\ When\ I\ Needed\ You\

I can also manually play  play /usr/share/sounds/KDE_Startup.wav 

but neither artsd nor esd are running.

bash-2.05a$ rpm -q arts
bash-2.05a$ rpm -q esd
package esd is not installed


The question about how to manually start the artsd was not answered, and I would
be interested in solving this on my host "couch"

... For what it is worth, in an attempt to resolve this, I did:

   chmod 666 /etc/dsp*

to get rid on one error which I was getting.  This set of files do not seem to
be under permissions control of the console permissions managementsystem, in
that the ownership is not being shifted, as I log in and out under various
userid's to test this.

Comment 6 Gerald Teschl 2002-05-08 15:07:35 EDT
It now works in 7.3. But the sound card is dead after a resume from sleep.
Comment 7 Gerald Teschl 2002-05-24 07:31:06 EDT
The remaining problem is not kde related. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.