Bug 62901 - Incorrect Links on /training/rhce/courses
Incorrect Links on /training/rhce/courses
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Site
Classification: Red Hat
Component: Elearning (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Web Development
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 09:09 EDT by Warren Togami
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-08 07:18:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-04-07 09:09:48 EDT
From Bugzilla Helper:  
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0; Linux)  
  
Description of problem:  
When I click on certain links ending with a "/" in the Red Hat Training site  
with the Konqueror web browser, the URL bar adds an unnecessary %20 character  
to the end.  Back button not available to return to the prior page.  
  
Version-Release number of selected component (if applicable):  
Skipjack beta2  
  
How reproducible:  
Always  
  
Steps to Reproduce:  
1. Go here in Konqueror http://www.redhat.com/training/rhce/courses/  
2. Click on "Student Guide" or "Certification Central" in the bottom left bar.   
These URL's end with a / character.  
3. Error 404 page because of the extraneous %20 character at the end of the  
URL.  
4. Click "Back".  It does not return to the prior page.  Instead it returns to  
the page viewed before that.   
   
  
Actual Results:    
Adds extraneous %20 to URL resulting in Error 404.  Back button lost knowledge  
of the last prior page, instead going to the one prior to the prior page.  
  
Expected Results:    
It should navigate properly in the first place.  Back shouldn't lose knowledge  
of the prior page.
Comment 1 Bernhard Rosenkraenzer 2002-04-08 05:51:57 EDT
Konqueror does the right thing. The link clearly points to 
"/training/student_guide/ " <- note the space (== %20) before the quotation mark. 
 
This happens to work in some other browsers because they are buggy; what konqueror does is 
the correct behavior. A browser must not ignore anything in the quotation marks. 
 
Reassigning to website so they can fix it. 
Comment 2 Warren Togami 2002-04-08 06:16:55 EDT
> Back shouldn't lose knowledge of the prior page.

What about this aspect of my report?  I believe this is clearly a Konqueror bug.
 Should I open another bug report or will this be fine?
Comment 3 Warren Togami 2002-04-08 07:18:31 EDT
I dug deeper into this problem, and I believe I found an obscure JavaScript bug
in Konqueror.  I detailed everything at this URL below with a few test cases
showing inconsistent behavior of hyperlinks and Konqueror losing knowledge of
the prior visited page when clicking Back.

http://www.mplug.org/archive/2002/konq_space_bug/

Note You need to log in before you can comment on or make changes to this bug.