Bug 62904 - xosview does not remember that it is sticky.
Summary: xosview does not remember that it is sticky.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-07 13:33 UTC by greg hosler
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 15:18:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of xprop of xosview after it is made sticky (708 bytes, text/plain)
2002-04-09 12:22 UTC, greg hosler
no flags Details

Description greg hosler 2002-04-07 13:33:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
I start up an Xosview. I move it to the upper right corner of the desktop. I set
it to sticky (so that it is on all desktops). I logout and "save settings".

I log back in. Xosview is restarted, but towards the upper left, not upper right
corner, and it is _not_ sticky.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start Xosview in a gnome session.
2. Position it to upper right corner. Set it to sticky, so that it is in all
desktops.
3. logout, save settings, log in.
	

Actual Results:  1) Xosview is restarted, but towards the upper left, not upper
right corner

2) it is _not_ sticky.

Expected Results:  Xosview should position itself in the correct position. and
it should be in all desktops (sticky set)

Additional info:

I'm not convinced that this is NOT a gnome bug, or a sawfish window manager bug.
Out of sympathy for the gnome people, I logged this to xosview for initial analysis.

Comment 1 Ngo Than 2002-04-07 17:46:02 UTC
It's a bug in window manager. It works for me with KDE 3

Comment 2 Havoc Pennington 2002-04-09 11:17:31 UTC
I need the output of "xprop" - run "xprop" click on the xosview window (after
it's been made sticky) and attach the output to this bug report.

Comment 3 greg hosler 2002-04-09 12:22:57 UTC
Created attachment 52828 [details]
output of xprop of xosview after it is made sticky

Comment 4 Havoc Pennington 2002-04-09 12:47:12 UTC
Yep, that should indeed be working.

Comment 5 greg hosler 2002-04-09 13:29:51 UTC
yup. and yet, when I click <foot> -> Logout. click on [] Save current setup.
then click []yes. and proceed to logout, and then log back in, neither the
position, nor the stickyness is restored.

This was an existing jome account, and I had problems in the early 7.92 betas, so
at the time I took the step of rm -rf ~/.gnome* ~/.nautil* (and only these), and
I was then able to log into gnome.

Perhaps I did not clean the slate enough ? What is the recommended way of wiping
the desktop slate clean, and then logging into what looks like a fresh
installation ?


Comment 6 Havoc Pennington 2002-04-09 15:18:32 UTC
Hmm, I didn't notice before that this is just session saving. So Sawfish doesn't
remember the sticky property on session save. This won't get fixed for the
immediate release-in-progress, but will probably be fixed for the release after.

To clear your session, you just have to remove ~/.gnome/session, not the whole 
.gnome (there's also ~/.gnome_private and ~/.gconf)

Comment 7 Havoc Pennington 2002-07-02 23:32:45 UTC
Should work in rawhide.


Note You need to log in before you can comment on or make changes to this bug.