Bug 62905 - Cannot create more than one account per session
Cannot create more than one account per session
Status: CLOSED DUPLICATE of bug 62308
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-users (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 10:01 EDT by William Shotts
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 14:14:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Shotts 2002-04-07 10:01:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
While using user manager in KDE, I cannot create more than one account per
session of the program.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log in as root in KDE
2.Start user manager
3.Create an account
4. Attempt to create a second user
	

Actual Results:  Pressing the new user button on the toolbar does not bring up
the entry dialog.  You must quit the program and restart it to add another user.

Expected Results:  New user entry dialog should appear after new user button is
clicked.

Additional info:
Comment 1 Warren Togami 2002-04-07 23:11:59 EDT
I just tested it in Gnome, it works fine there.    
    
This appears to be a duplicate of Bug 62308 where KDE window manager is not    
honoring WM hints.  redhat-config-users works fine in KDE, except the new Add  
User dialogue is appearing beneith the main window the second time you use it.  
  
If this is in fact a duplicate, then this is a kdebase component bug.
Comment 2 Brent Fox 2002-04-08 11:17:34 EDT
bshotts, are you running the program from the command line?  If not, try doing
that.  Perhaps there is a traceback or error message that you can't see if you
run it from the menu.

Also, you should upgrade to
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/
Fileredhat-config-users-1.0-10.noarch.rpm

since I've fixed some bugs since 1.0-8.  Does 1.0-10 make the problem go away?
Comment 3 Brent Fox 2002-04-08 16:04:16 EDT
Correction, grab redhat-config-users-1.0-11 instead.
Comment 4 William Shotts 2002-04-08 19:25:33 EDT
redhat-config-users-1.0-10.noarch.rpm (11 not on the rawhide site) fails to come
up with the follwoing error messages:

redhat-config-users (pid:1672): Gdk-WARNING **: locale not supported by Xlib

redhat-config-users (pid:1672): Gdk-WARNING **: can not set locale modifiers

redhat-config-users (pid:1672): Gtk-WARNING **: Unable to locate theme engine in
module_path: "raleigh",

redhat-config-users.py (pid:1677): Gdk-WARNING **: locale not supported by Xlib

redhat-config-users.py (pid:1677): Gdk-WARNING **: can not set locale modifiers
warning: failed to load external entity "./redhat-config-users.glade"

redhat-config-users.py (pid:1677): libglade-WARNING **: document not well formed!
Traceback (most recent call last):
  File "/usr/share/redhat-config-users/redhat-config-users.py", line 26, in ?
    import mainWindow
  File "/usr/share/redhat-config-users/mainWindow.py", line 91, in ?
    xml = gtk.glade.XML ("./redhat-config-users.glade",
domain="redhat-config-users")
RuntimeError: could not create GladeXML object


As to the original error, warren@togami.com is correct, the user dialog appears
under the application window.
Comment 5 Warren Togami 2002-04-08 20:58:52 EDT
How long does it take for new packages to reach rawhide?
redhat-config-users-1.0-11 is not there yet.  subversion 10 is indeed broken
with the same error above.

Comment 6 Brent Fox 2002-04-09 10:06:10 EDT
It usually appears the next day.  redhat-config-users-1.0-12.noarch.rpm is there
now.  Can you give that a try?
Comment 7 Warren Togami 2002-04-09 14:13:58 EDT
tested -12.noarch.rpm.  It no longer crashes like -10.noarch.rpm, but it doesn't
fix the original problem that is most likely the KDE window manager not
acknowleding WM hints in Bug 62308.
Comment 8 Brent Fox 2002-04-09 14:29:07 EDT
Ok.  At the very least, we tracked down some bugs in redhat-config-users...they
just weren't bugs related to this particular problem.  I now agree that the
behavior here is a KDE problem.  The New User window appears on top the first
time.  But every time you launch the window after that, it appears under the
parent window.

I'm going to dupe this against bug 62308

*** This bug has been marked as a duplicate of 62308 ***

Note You need to log in before you can comment on or make changes to this bug.