Bug 62906 - smtp client doesn't work in default setup
smtp client doesn't work in default setup
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: postfix (Show other bugs)
skipjack-beta2
All Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-04-07 10:12 EDT by Eric Hopper
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 17:03:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Hopper 2002-04-07 10:12:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020326

Description of problem:
The smtp client is set up in /etc/postfix/master.cf to be run chrooted.  The
postfix directories have not been properly set up so that the smtp client can
run that way.  The symptom is that the client is unable to do DNS lookups of MX
records for domains it's sending mail to and the messages are forever 'deferred'.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set up postfix
2.Try to send mail to ouside
3.Look for the DNS lookup failure messages in /var/logs/maillog
	

Actual Results:  DNS lookup failures in /var/logs/maillog, and the mail sits in
queue

Expected Results:  Successfully delivered mail

Additional info:

I changed the smtp client to not run chrooted in master.cf and things worked
fine.  This, of course, is not a good solution.  The directories should be set
up so that it actually works to run the smtp client chrooted.

In the postfix source tarball, this file seems to contain a shell script
designed to make that happen.  I haven't checked it out a lot myself, but here's
the file:

postfix-1.1.7/examples/chroot-setup/LINUX2
Comment 1 Bernhard Rosenkraenzer 2002-04-15 07:29:25 EDT
This was caused by libdb-3.3.so missing from the chroot enviroment. Fixed in 
1.1.7-2.
Comment 2 Eric Hopper 2002-04-15 07:36:13 EDT
Thanks! :-)

Note You need to log in before you can comment on or make changes to this bug.