Bug 62907 - ksplash crashes first time it is run
Summary: ksplash crashes first time it is run
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2002-04-07 14:19 UTC by William Shotts
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 21:02:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash trace (1.86 KB, text/plain)
2002-04-07 14:45 UTC, Hugo Varotto
no flags Details

Description William Shotts 2002-04-07 14:19:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
ksplash crashes the first time KDE is brought up on each account.  It reports a
segfault at or near the conclusion of its execution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start KDE for the first time on an account
2.Choose the defaults for everything in the configuration wizard
3.ksplash starts and seems to finish
	

Actual Results:  Crash dialog appears indicating a segfault has occured.  This
only happens on the first login.  Works properly after that.

Expected Results:  ksplash terminates normally

Additional info:

This happened on a slow machine (Pentium 200/96Mb).  Machine starts up in text
mode (run level 3).

Comment 1 Hugo Varotto 2002-04-07 14:45:11 UTC
Created attachment 52624 [details]
Crash trace

Comment 2 Hugo Varotto 2002-04-07 14:50:20 UTC
According to a mail saw in the KDEVELOP mailing list, RedHat missed a patch to
the QT library in QCommonStyle. Looking at the trace, it seems that the crash
happened inside QCommonStyle::drawControl  Could this be the reason ?

I'm attaching the e-mail that mentions that. 

Hugo

----------
Date: Sat, 6 Apr 2002 12:01:57 -0500
From: Maksim Orlovich <mo002j@mail.rochester.edu>
To: 40258@bugs.kde.org
Reply to: kdevelop-devel@kdevelop.org
Checking RedHat's Qt3 RPMs, looks like they didn't apply
a patch to Qt that prevents divide-by-zero crashes in QCommonStyle,
and the BT looks exactly like that bug..

I am somewhat inclined to close this, myself, but since this is in KDevelop 
land I'll leave it as it is...

Thanks,
Maks Orlovich
--------



Comment 3 Bernhard Rosenkraenzer 2002-04-08 10:42:39 UTC
Which version of Qt are you using? I'm not seeing this with 3.0.3-7

Comment 4 William Shotts 2002-04-08 23:27:41 UTC
skipjack beta 2 contains qt-3.0.3-6

Comment 5 Ben Levenson 2002-04-09 21:15:25 UTC
I'm also unable to reproduce this w/ 3.0.3-7. Closing as RESOLVED:RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.