Bug 629078 - [abrt] crash in phatch-cli-0.2.7-1.fc13: api.py:777:apply_actions_to_photo:AttributeError: 'NoneType' object has no attribute 'close'
Summary: [abrt] crash in phatch-cli-0.2.7-1.fc13: api.py:777:apply_actions_to_photo:At...
Keywords:
Status: CLOSED DUPLICATE of bug 646035
Alias: None
Product: Fedora
Classification: Fedora
Component: phatch
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Narasimhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:680fa008
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-31 20:42 UTC by Michal Pomorski
Modified: 2011-05-12 19:37 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-12 19:37:24 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.40 KB, text/plain)
2010-08-31 20:42 UTC, Michal Pomorski
no flags Details
an error message appearing (28.87 KB, image/png)
2011-02-10 13:25 UTC, Vratislav Podzimek
no flags Details
log window (65.54 KB, image/png)
2011-02-10 13:25 UTC, Vratislav Podzimek
no flags Details
action list used (1.06 KB, application/x-phatch)
2011-02-10 13:26 UTC, Vratislav Podzimek
no flags Details

Description Michal Pomorski 2010-08-31 20:42:44 UTC
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/phatch
component: phatch
executable: /usr/bin/phatch
kernel: 2.6.33.5-124.fc13.i686
package: phatch-cli-0.2.7-1.fc13
reason: api.py:777:apply_actions_to_photo:AttributeError: 'NoneType' object has no attribute 'close'
release: Fedora release 13 (Goddard)

backtrace
-----
api.py:777:apply_actions_to_photo:AttributeError: 'NoneType' object has no attribute 'close'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/phatch/pyWx/gui.py", line 701, in on_menu_tools_execute
    self._execute(actionlist)
  File "/usr/lib/python2.6/site-packages/phatch/pyWx/gui.py", line 300, in _execute
    update=self._send_update_event, **keyw)
  File "/usr/lib/python2.6/site-packages/phatch/core/api.py", line 729, in apply_actions_to_photos
    is_done, image_index, repeat)
  File "/usr/lib/python2.6/site-packages/phatch/core/api.py", line 777, in apply_actions_to_photo
    photo.close()
AttributeError: 'NoneType' object has no attribute 'close'

Local variables in innermost frame:
repeat: 1
image_index: 0
photo: None
cache: {}
is_done: <bound method Action.is_done of <actions.rename.Action object at 0x958266c>>
actions: [<actions.rename.Action object at 0x958266c>]
image_info: {'index': 0, 'folderindex': 2, 'subfolder': u'', 'path': u'/home/xxxx/Desktop/Screenshot-1.png', 'folder': u'/home/misiek/Desktop', 'filename': u'Screenshot-1', 'type': u'png', 'root': u'/home/misiek', 'foldername': u'Desktop'}
info_not_file: <lib.metadata.InfoExtract instance at 0x98817ac>
result: {'answer': u'abort', 'skip': False, 'abort': True, 'stop_for_errors': True, 'last_answer': None}
read_only_settings: <lib.odict.ReadOnlyDict instance at 0x9881fec>
report: []
skip_existing_images: True

How to reproduce
-----
1.Try to rename using an exif tag that does not exist in the image
2. On the error message, press cancel (or maybe its abort)
3. Error happens

Comment 1 Michal Pomorski 2010-08-31 20:42:46 UTC
Created an attachment (id=442275)
File: backtrace

Comment 2 Łukasz Jernaś 2010-11-29 21:52:11 UTC
Package: phatch-cli-0.2.7-3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Tried to resample some images with "Scale" and "Save" in the list

Comment 3 Russell Harrison 2010-11-30 16:42:01 UTC
Package: phatch-cli-0.2.7-3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Open existing action list in phatch
2. View droplet for action list
3. Drop several files onto the droplet

Comment 4 Russell Harrison 2010-11-30 17:02:28 UTC
This seems to be caused by the upgrade of pyexiv2.  Apparently the API is slightly different.

https://bugs.launchpad.net/phatch/+bug/585169

Comment 5 Pockey Lam 2010-12-03 07:31:05 UTC
Package: phatch-cli-0.2.7-3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Open pictures under phatch
2.
3.


Comment
-----
Unable to open the jpg files , there is error

Comment 6 Sylvain Peuret 2010-12-16 21:22:09 UTC
Package: phatch-cli-0.2.7-3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.En lancant un traitement par lot de renomage de fichier
2.
3.

Comment 7 Cristian Ciupitu 2011-01-07 01:37:23 UTC
Package: phatch-cli-0.2.7-3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. +
2. Fit
3. Save
4. Error
5. Abort
6. Tried to close the program

Comment 8 Nuno Dias 2011-01-30 15:55:36 UTC
Package: phatch-cli-0.2.7-3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.  Run phatch
2. Execute the action
3.

Comment 9 Vratislav Podzimek 2011-02-10 13:22:28 UTC
Package: phatch-cli-0.2.7-3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I was trying to process image files in the directory with action list (attached)
2. Just an error message appeared and it was followed by the log window (both attached)


Comment
-----
The same action list works without any problems with different folder of photos

Comment 10 Vratislav Podzimek 2011-02-10 13:25:04 UTC
Created attachment 478048 [details]
an error message appearing

Comment 11 Vratislav Podzimek 2011-02-10 13:25:52 UTC
Created attachment 478049 [details]
log window

Comment 12 Vratislav Podzimek 2011-02-10 13:26:49 UTC
Created attachment 478050 [details]
action list used

Comment 13 Cristian Ciupitu 2011-02-12 15:18:34 UTC
Package: phatch-cli-0.2.7-3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I don't remember.

Comment 14 Fedora Admin XMLRPC Client 2011-02-13 02:58:04 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 15 Narasimhan 2011-03-23 14:39:37 UTC
Waiting for the bug to be fixed in 0.2.8 (according the bug in launchpad). This is bug that is being tracked

https://bugs.launchpad.net/phatch/+bug/566141

Comment 16 Alfredo Rubio 2011-05-10 16:15:51 UTC
Package: phatch-cli-0.2.7-3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Trying rescaling images jpg
2.
3.


Comment
-----
Phatch error with pyexiv2-0.3.0-1 and exiv2-libs-0.21.1-1. No error with earlier versions like pyexiv2-0.1.3-11 and exiv2-libs-0.20-1

Comment 17 Narasimhan 2011-05-12 19:36:17 UTC
I was able to fix the crash problem and also this issue 

Error 0:Unable to open file: <abc>.jpg:
'module' object has no attribute 'Image'

After this fix, jpg files can be processed without any issues. Will create an update.

Comment 18 Narasimhan 2011-05-12 19:37:24 UTC

*** This bug has been marked as a duplicate of bug 646035 ***


Note You need to log in before you can comment on or make changes to this bug.