Bug 62917 - bloat installed during upgrade
Summary: bloat installed during upgrade
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-07 17:21 UTC by Gene Czarcinski
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 14:50:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
6.2 install log (9.60 KB, text/plain)
2002-04-07 17:23 UTC, Gene Czarcinski
no flags Details
7.2.93 upgrade log (83.15 KB, text/plain)
2002-04-07 17:23 UTC, Gene Czarcinski
no flags Details
rpm -qa from 6.2 system (7.67 KB, text/plain)
2002-04-07 17:23 UTC, Gene Czarcinski
no flags Details
rpm -qa from system upgraded to 7.2.93 (11.75 KB, text/plain)
2002-04-07 17:24 UTC, Gene Czarcinski
no flags Details

Description Gene Czarcinski 2002-04-07 17:21:17 UTC
Description of Problem:
Performing an up from 6.2 to 7.2.93, emacs, emacs-el, and lots of kde-i18n*
packages installed during upgrade but NOT in original system

Version-Release number of selected component (if applicable):

6.2 -> 7.2.93
How Reproducible:
create 6.2 system with gnome + kde but NO emacs.  Then do upgrade to 7.2.93

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
bloat installed

Expected Results:
minimum extra such as sawfish but NOT emacs

Additional Information:
	
The original 6.2 system used about 860MB of disk space.  The upgraded system
used over 1800MB of disk space.  The emacs and kde-i18n packages are just the
most obvious.  There are likely lots of others.

Comment 1 Gene Czarcinski 2002-04-07 17:23:01 UTC
Created attachment 52625 [details]
6.2 install log

Comment 2 Gene Czarcinski 2002-04-07 17:23:32 UTC
Created attachment 52626 [details]
7.2.93 upgrade log

Comment 3 Gene Czarcinski 2002-04-07 17:23:59 UTC
Created attachment 52627 [details]
rpm -qa from 6.2 system

Comment 4 Gene Czarcinski 2002-04-07 17:24:31 UTC
Created attachment 52628 [details]
rpm -qa from system upgraded to 7.2.93

Comment 5 Gene Czarcinski 2002-04-08 13:11:02 UTC
I have found that the same packages have been added in a 7.2->beta4 upgrade.  If
you need the info from that system, just ask.

Comment 6 Jeremy Katz 2002-04-09 00:40:56 UTC
kde-i18n-* are added due to movements of kde translations.  emacs and emacs-el
are added from files moving from the gettext package.  anaconda's orphan file
handling is probably too aggressive for today.  Too late to make changes for
this release, though.

Comment 7 Jeremy Katz 2002-06-28 04:11:10 UTC
Fixed by changing the upgrade algorithm

Comment 8 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated

Comment 9 Brent Fox 2003-05-25 14:50:22 UTC
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.


Note You need to log in before you can comment on or make changes to this bug.