Bug 62920 - 'nautilus' does not come up after starting 'GNOME' session
'nautilus' does not come up after starting 'GNOME' session
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 14:30 EDT by Joachim Frieben
Modified: 2007-04-18 12:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 08:37:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2002-04-07 14:30:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
After launching a GNOME session there are no icons on the desktop. This is due
to 'nautilus' not running properly or not running at all.

Version-Release number of selected component (if applicable):
1.0.6-11

How reproducible:
Sometimes

Steps to Reproduce:
1. Log in to GNOME session


Actual Results:  The very first GNOME session always behaves correctly. However,
from the second session on, the GNOME desktop appears, but X clients saved from
a previous session are stalled. They all pop up immediately, as soon as one
manually launches some X client. But then, there are still no icons on the
desktop. Checking the presence of some running nautilus process yields different
results. (Re)-launching 'nautilus' by executing 'nautilus' by hand sometimes
makes the icons of home directory and trash bin appear, but never the 'Start
here' icon.

Expected Results:  The full 'GNOME' should appear shortly after logging in to a
'GNOME' session.

Additional info:

This used to work in the past for the various versions of Red Hat Linux,
including 'Skipjack 1'. The behaviour is the same for two very different
machines: an HP Visualize X-Class workstation running the 'Xhp*' server (based
upon XFree86), and a DELL C810 notebook running the 'XFree86*' server.
Comment 1 Ian Prowell 2002-04-07 19:36:29 EDT
When I installed Skipjack Beta 2 I had the same problem when I was using a DHCP
address.  I changed the machine to a static IP which was listed in DNS and
Nautilus seemed to function properly.  This may be a name lookup problem.
Comment 2 adam.huffman 2002-04-08 07:13:03 EDT
I have this problem too.  Setting a static IP and hostname doesn't seem to make
any difference (I am using DHCP at the moment).
Comment 3 Saul 2002-04-08 15:48:44 EDT
Same in my gnome session nautilus not run, I tried to update mozilla and
nautilus with rawhide ones, but nothing. I have dhcp network on an e-smith 5.1.2.
Sometimes nautilus window can run on kde.
Comment 4 Havoc Pennington 2002-04-09 07:24:37 EDT
Can you guys try running "gnome-login-check" and "gconf-sanity-check-1" and 
see if you get any dialogs or output?
Comment 5 adam.huffman 2002-04-09 09:10:13 EDT
Don't get anything for gnome-login-check

For gconf-sanity-check-1 I get:

Please contact your system administrator to resolve the following problem:
Failed to get a file lock: Failed to lock '/home/adam/.gconfd/lock/ior':
probably another process has the lock, or your operating system has NFS file
locking misconfigured, or a hard NFS client crash caused a stale lock (Resource
temporarily unavailable) - run gconf-sanity-check-1 for possible diagnosis, see
http://www.gnome.org/projects/gconf/ for more information
Comment 6 Havoc Pennington 2002-04-09 11:16:48 EDT
There was an xinetd bug fixed apparently that was causing Nautilus hangs on 
the second and subsequent logins (xinetd gets involved in starting the FAM
service). So this may have been it.

The gconf-sanity-check warning is potentially worrisome, though it could also be
bogus. If you have a "gconfd-1" process running (ps jaxwww | grep gconf) then 
it's probably bogus, if no gconfd-1 then one of the problems mentioned in the 
message or at the URL in the message probably applies.
Comment 7 Saul 2002-04-09 11:58:01 EDT
I had the same message when i do gconf-sanity-check-1, but I was root and the
directory was '/root/.gconfd/lock/ior'.
I uninstall the network and everythings seems to be good.
When I put the nic again, on second gnome-session, nautilus stop working.
Comment 8 Saul 2002-04-09 12:00:44 EDT
I forgot I have got one gconfd-1 running
Comment 9 Alexander Larsson 2002-04-09 12:05:22 EDT
Try upgrading to xinetd  2.3.4-0.8 from rawhide. The shut down portmap and
xinetd and then start them again. That should hopefully fix this.
Comment 10 Saul 2002-04-09 12:16:13 EDT
Very Nice it goes
Comment 11 Joachim Frieben 2002-04-10 08:37:25 EDT
After installing 'xinetd-2.3.4-0.8' and removing the '.' directories, everything
works now as expected. Thanks!
Comment 12 Havoc Pennington 2002-04-10 11:38:45 EDT
Counting this as fixed then, thanks.

Note You need to log in before you can comment on or make changes to this bug.