Bug 629214 - license violation - phpMyAdmin (GPLv2) bundles OLE (PHP)
license violation - phpMyAdmin (GPLv2) bundles OLE (PHP)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: phpMyAdmin (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On: 725914
Blocks: FE-Legal DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2010-09-01 06:09 EDT by Iain Arnell
Modified: 2011-10-03 14:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: phpMyAdmin3-3.4.5-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-27 18:58:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Iain Arnell 2010-09-01 06:09:24 EDT
phpMyAdmin bundles a copy of PHPExcel library, which in turn bundles a copy of OLE (already packaged as php-pear-OLE).

phpMyAdmin is GPLv2+; PHPExcel is LGPLv2+; but OLE is PHP license. Most of the OLE files have headers stating "version 2.02 of the PHP license". 

In OLE's upstream, however, ChainedBlockStream.php is clearly licensed under "version 3.0 of the PHP license", whereas in phpMyAdmin's bundled copy, the header has been replaced with one claiming LGPLv2+. There are no other substantial changes to the file (the only change being to explicitly declare member functions and variables as public).

I would contend that the bundled ChainedBlockStream.php is clearly derived from OLE's upstream version and as a result, PHPv3's condition 4 would prohibit both PHPExcel and phpMyAdmin from using "PHP" in their names.

PHPExcel's upstream are aware of the issue[1], but I see no sign of any resolution.

Of course, the proper solution from our side would be to unbundle PHPExcel from phpMyAdmin and patch PHPExcel to use the system php-pear-OLE library.

[1] http://phpexcel.codeplex.com/Thread/View.aspx?ThreadId=83335
Comment 1 Tom "spot" Callaway 2010-09-01 08:49:41 EDT
I agree here. The clearest solution would be to unbundle PHPExcel from phpMyAdmin and patch it to use php-pear-OLE.
Comment 2 Fedora Admin XMLRPC Client 2011-04-05 04:59:40 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Tom "spot" Callaway 2011-06-30 13:07:45 EDT
Hey new owner, please try to address this issue. I would normally just dive in and do it, but my PHP skills are weak at best.
Comment 4 Robert Scheck 2011-07-26 11:00:19 EDT
Sorry, PHPExcel is still not packaged for Fedora. And the OLE that is used by
PHPExcel seems to be a slightly forked copy.
Comment 5 Tom "spot" Callaway 2011-07-26 11:33:05 EDT
Do you plan on working on this, or should we just retire phpMyAdmin? :)
Comment 6 Robert Scheck 2011-07-26 20:15:15 EDT
Can we retire phpMyAdmin at upstream, please? Even if retiring phpMyAdmin at
downstream would be also cool, this issue needs to be solved, I think...

Tom, do you want to help? I would need a package review for bug #725914, which
is required to get PHPExcel as "php-pear-PHPExcel" done.
Comment 7 Robert Scheck 2011-07-31 18:15:49 EDT
Tom, I'm not sure if PHPExcel can be packaged as it is - even when we patch it
to use the system php-pear-OLE. The upstream PHPExcel package bundles some more 
foreign libraries, I think. May you do a legal check?
Comment 8 Tom "spot" Callaway 2011-08-02 12:03:48 EDT
Well, it has TCPDF (LGPLv3+) bundled inside of it, and I think I've already made my concerns about it clear (re: bundling of fonts in odd ways), but from a strict licensing perspective, here's what I found:

* TCPDF (overall LGPLv3+, but bundles the following fonts):
 - Al-Mohanad (unknown license)
 - dejavu-*-fonts (Bitstream Vera and Public Domain, in Fedora)
 - gnu-free-fonts (GPLv2+ with font exception, in Fedora)
 - Zar Bold (GPLv2+)

It also has:

* JAMA (mix of Public Domain and PHP), closest thing to an upstream I could find was here: http://php.livejournal.com/270125.html
* OLE/PPS (PHP) derived from,OLE::Storage_Lite
* PclZip (GPL+ or LGPLv2+)

The rest is LGPLv2+.

Excluding the fonts, there are no licensing compatibility concerns, and I'm not going to give myself a headache and consider the license compatibility issues with embedded fonts in the php code to the rest of the php code. The notable exception is Al-Mohanad, which either needs to have its license identified or simply removed.

So, in conclusion: Bundling galore, including particularly nasty TCPDF, but licensing is okay at: "LGPLv2+ and LGPLv3+ and PHP", assuming that the fonts are unbundled (if even possible, it may not be) and Al-Mohanad is removed.

There's a lot of assumptions in there. TCPDF is going to be a holy terror to package properly.
Comment 9 Fedora Update System 2011-09-17 20:44:04 EDT
phpMyAdmin-3.4.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/phpMyAdmin-3.4.5-1.fc16
Comment 10 Fedora Update System 2011-09-17 20:45:59 EDT
phpMyAdmin-3.4.5-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/phpMyAdmin-3.4.5-1.fc15
Comment 11 Fedora Update System 2011-09-17 20:46:34 EDT
phpMyAdmin-3.4.5-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/phpMyAdmin-3.4.5-1.fc14
Comment 12 Fedora Update System 2011-09-17 20:47:11 EDT
phpMyAdmin-3.4.5-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/phpMyAdmin-3.4.5-1.el6
Comment 13 Fedora Update System 2011-09-17 20:48:08 EDT
phpMyAdmin3-3.4.5-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/phpMyAdmin3-3.4.5-1.el5
Comment 14 Fedora Update System 2011-09-18 13:08:44 EDT
Package phpMyAdmin-3.4.5-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing phpMyAdmin-3.4.5-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/phpMyAdmin-3.4.5-1.el6
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2011-09-27 18:58:03 EDT
phpMyAdmin-3.4.5-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2011-09-27 19:06:53 EDT
phpMyAdmin-3.4.5-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2011-09-30 15:35:41 EDT
phpMyAdmin-3.4.5-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2011-10-03 14:02:57 EDT
phpMyAdmin-3.4.5-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2011-10-03 14:04:00 EDT
phpMyAdmin3-3.4.5-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.