Bug 629229 - new version available and shipped version has disappeared [NEEDINFO]
Summary: new version available and shipped version has disappeared
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-Spreadsheet-ParseExcel   
(Show other bugs)
Version: el5
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: UpdatePackage
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-01 11:24 UTC by Patrice Dumas
Modified: 2016-04-05 17:53 UTC (History)
6 users (show)

Fixed In Version: perl-Spreadsheet-ParseExcel-0.3200-3.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-05 17:53:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jpazdziora: needinfo? (steve)


Attachments (Terms of Use)

Description Patrice Dumas 2010-09-01 11:24:40 UTC
Description of problem:

The source for this package cannot be found anymore.

I noticed this because I found a bug when parsing an excel document. My wild guess is that the issue is in the OLE parser, but it would certainly be better to update this software anyway given that the previous source disappeared.

Version-Release number of selected component (if applicable):

0.3200-2.el5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mark Chappell 2010-09-15 07:37:00 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=2468796

Looks like this should be an easy rebase...  rawhide spec builds fine.

Comment 2 Patrice Dumas 2011-01-12 13:43:57 UTC
rawhide source has also disapeared.
I tried to rebuild the latest release (there is a change, no more Build.PL, only Makefile.PL).  It compiles fine on Centos 5, and it fixes my bug.

Comment 3 Jan Pazdziora 2016-03-14 08:33:09 UTC
Is the main concern here that the Source0 line is no longer valid? We could easily change that to backpan.perl.org.

I'm not sure we want to rebase.

Comment 4 Patrice Dumas 2016-03-14 10:07:33 UTC
I was more concerned about a bug I found than strictly about the source not being available. I have stopped using EPEL5 some time ago, though. In 2011, I rebuilt locally a rpm, probably based on the rawhide version of the day, 0.5800. As I am no longer a user, I do not think my advice matters that much...

Comment 5 Jan Pazdziora 2016-03-14 18:11:20 UTC
Thank you.

Steven, do we need to respin the build with valid source URL or can we WONTFIX this bugzilla?

An alternative would be to rebase to some newer version ... but I guess, similar to Patrice, people might no longer be expecting fresh versions in EPEL 5.

Comment 6 Jan Pazdziora 2016-03-21 13:52:26 UTC
Taking.

Comment 7 Jan Pazdziora 2016-03-21 13:55:46 UTC
Changed Source0 to point to BackPan so that we have live upstream source URL.

Comment 8 Fedora Update System 2016-03-21 13:57:34 UTC
perl-Spreadsheet-ParseExcel-0.3200-3.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5913e4f720

Comment 9 Fedora Update System 2016-03-22 00:18:29 UTC
perl-Spreadsheet-ParseExcel-0.3200-3.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5913e4f720

Comment 10 Fedora Update System 2016-04-05 17:53:03 UTC
perl-Spreadsheet-ParseExcel-0.3200-3.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.