Bug 62928 - UTF8 locale not usable
UTF8 locale not usable
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 17:06 EDT by Michel Alexandre Salim
Modified: 2015-01-07 18:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-27 19:56:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2002-04-07 17:06:41 EDT
Description of Problem:  
Since GNOME2/GTK2 uses UTF8 by default, I tried using a UTF8 locale so that  
KDE can display files created in GNOME2 (beta3) properly. locale_config does  
not show UTF8 locales even though they are present in glibc-common  
(/usr/lib/locale/en_GB.utf8 for instance). Forcing /etc/sysconfig/i18n to use  
the new locale, trying ls on a directory that contains UTF8-encoded filenames  
show that the locale is not used properly; starting KDE resets the locale back  
to en_GB. So I set LC_ALL=en_GB.utf8 in a terminal window and run a KDE app;  
the result is  
	 Qt: Locales not supported on X server 
  
Version-Release number of selected component (if applicable):  
 Skipjack beta2 
  
How Reproducible:  
 Always 
  
Steps to Reproduce:  
1. Set /etc/sysconfig/i18n's LANG to a UTF8 locale  
2. Restart 
3. Try ls on a directory containing UTF8 filenames, try launching KDE 
  
Actual Results:  
 File names still not displayed properly, KDE resets to non-UTF8 locale. 
Forcing it to UTF8 and launching a program from a terminal window yields 
	Qt: Locales not supported on X server 
  
Expected Results:  
 UTF8 filenames displayed properly in console; KDE accepts UTF8  
  
Additional Information:  
  Seems like a lack of UTF8 fonts
Comment 1 Michel Alexandre Salim 2002-04-07 21:31:24 EDT
Works when /etc/sysconfig/desktop is set to DESKTOP="KDE" - either that, or it 
was because I was using the XftConfig that came with skipjack beta1 and did 
not include the directories with Korean, Chinese and Japanese fonts while 
anti-aliasing is turned on. Could it be verified? Thanks..
Comment 2 Mike A. Harris 2002-05-26 00:51:43 EDT
The distribution does not fully support UTF8 currently.

Bero, care to add any additional comment?
Comment 3 Charles Lopes 2002-06-04 04:45:16 EDT
Stock Xlib will only recognize a locale in the form -.UTF-8 while glibc will
accept -.utf8 -.utf-8 or -.UTF8 as well. I suppose aliases could be defined in
/usr/X11R6/lib/X11/locale/locale.aliases.
Comment 4 Preston Brown 2002-06-27 19:56:45 EDT
Our next release of Red Hat Linux will support UTF-8 (for at least western
languages) out of the box.
Comment 5 Michel Alexandre Salim 2002-07-09 04:10:05 EDT
Should be supported in 7.3.92 and above

Note You need to log in before you can comment on or make changes to this bug.