Bug 62933 - posgresql-python: import pg traceback
posgresql-python: import pg traceback
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: postgresql (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 20:39 EDT by David M. Cook
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-07 23:51:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David M. Cook 2002-04-07 20:39:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-0.8 i586)

Description of problem:
When importing pg, get the following traceback:

[dmcook@localhost tmp]$ /sbin/service postgresql status
postmaster (pid 16664 16663 16661) is running...
[dmcook@localhost tmp]$ python -v -c 'import pg'
# /usr/lib/python1.5/exceptions.pyc matches /usr/lib/python1.5/exceptions.py
import exceptions # precompiled from /usr/lib/python1.5/exceptions.pyc
# /usr/lib/python1.5/site.pyc matches /usr/lib/python1.5/site.py
import site # precompiled from /usr/lib/python1.5/site.pyc
# /usr/lib/python1.5/os.pyc matches /usr/lib/python1.5/os.py
import os # precompiled from /usr/lib/python1.5/os.pyc
import posix # builtin
# /usr/lib/python1.5/posixpath.pyc matches /usr/lib/python1.5/posixpath.py
import posixpath # precompiled from /usr/lib/python1.5/posixpath.pyc
# /usr/lib/python1.5/stat.pyc matches /usr/lib/python1.5/stat.py
import stat # precompiled from /usr/lib/python1.5/stat.pyc
# /usr/lib/python1.5/UserDict.pyc matches /usr/lib/python1.5/UserDict.py
import UserDict # precompiled from /usr/lib/python1.5/UserDict.pyc
Python 1.5.2 (#1, Mar 26 2002, 17:37:49)  [GCC 2.96 20000731 (Red Hat Linux 7.2
2 on linux-i386
Copyright 1991-1995 Stichting Mathematisch Centrum, Amsterdam
# /usr/lib/python1.5/site-packages/pg.pyc matches
/usr/lib/python1.5/site-packages/pg.py
import pg # precompiled from /usr/lib/python1.5/site-packages/pg.pyc
Traceback (innermost last):
  File "<string>", line 1, in ?
  File "/usr/lib/python1.5/site-packages/pg.py", line 7, in ?
    from _pg import *
ImportError: /usr/lib/python1.5/site-packages/_pgmodule.so: undefined symbol:
_PyString_Join


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.python -v -c 'import pg'
2.
3.
	

Actual Results:  Get a traceback.	

Expected Results:  Module pg ready for use.

Additional info:

This is a system that was upgraded from 7.2.92 to 7.2.93 via RHN.   Current
python and postgresql packages are:

postgresql-python-7.2.1-2
python-1.5.2-37
postgresql-libs-7.2.1-2
postgresql-7.2.1-2
postgresql-devel-7.2.1-2
postgresql-server-7.2.1-2
Comment 1 David M. Cook 2002-04-07 23:50:58 EDT
_PyString_Join is used on line 143 of Eliot Lee's betterquote patch,
postgresql-7.2rc2-betterquote.patch.  Looks like _PyString_Join is a python2
thing, though.
Comment 2 Trond Eivind Glomsrxd 2002-04-08 10:52:21 EDT
Fixed in 7.2.1-3

Note You need to log in before you can comment on or make changes to this bug.