Bug 629366 - Hard lockup with kernel 2.6.34.6-47.fc13 when Wacom tablet is attached during boot
Hard lockup with kernel 2.6.34.6-47.fc13 when Wacom tablet is attached during...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 629385 630909 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-01 15:13 EDT by Stephen Haffly
Modified: 2010-09-27 00:05 EDT (History)
20 users (show)

See Also:
Fixed In Version: kernel-2.6.34.7-56.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 21:30:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dmesg log (57.92 KB, text/plain)
2010-09-01 15:13 EDT, Stephen Haffly
no flags Details
Xorg.0.log file (18.61 KB, text/plain)
2010-09-02 19:23 EDT, Stephen Haffly
no flags Details
Picture of screen just before blanking (530.17 KB, image/png)
2010-09-03 09:43 EDT, Stephen Haffly
no flags Details
Comment (68.63 KB, text/plain)
2010-09-02 14:58 EDT, Dennis Appelon Nielsen
no flags Details

  None (edit)
Description Stephen Haffly 2010-09-01 15:13:33 EDT
Created attachment 442480 [details]
Dmesg log

Description of problem:
Kernel updated via yum to version 2.6.34.6-47.fc13.x86_64.  Upon reboot, screen goes to black and keyboard/mouse become totally non-responsive, requiring reboot back to previous kernel level 2.6.33.8-149.fc13.x86_64.  Power switch on CPU will initiate shutdown, but no keyboard input available.  This is with nVidia graphics, with appropriate kmod.

Version-Release number of selected component (if applicable):
2.6.34.6-47.fc13.x86_64

How reproducible:
yum update (installs kernel, kernel headers, and kmod-nvidia.  Upon reboot, just after Fedora Infinity logo is fully filled and when it should be switching to the login screen, the screen goes blank and the system will not respond.

Steps to Reproduce:
1. Update kernel
2. reboot
3. hard lockup
  
Actual results:
hard lockup, non-responsive keyboard/mouse, blank screen

Expected results:
Should see it proceed to the normal login screen.

Linux (removed) 2.6.33.8-149.fc13.x86_64 #1 SMP Tue Aug 17 22:53:15 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

Additional info:
Comment 1 Chuck Ebbert 2010-09-01 19:53:06 EDT
Does the nouveau driver work in place of the nvidia driver?
Comment 2 Stephen Haffly 2010-09-01 21:54:00 EDT
I removed the akmod-nvidia and kmod-nvidia packages to revert to the nouveau driver.  The nouveau driver works well with the previous kernel, but I still get a lockup at the point where it should be switching to the login screen with the new kernel.
Comment 3 Stephen Haffly 2010-09-02 12:51:02 EDT
On Fedora Forums, there is a thread that suggested unplugging my Wacom tablet (Graphire 3, CTE-630).

http://forums.fedoraforum.org/showthread.php?t=250891

I did so and the computer booted up normally.  The problem does not seem to lie with the video subsystem, but with the Wacom tools.

Are there any tests I can run to help narrow down the problem?
Comment 4 Chuck Ebbert 2010-09-02 13:19:39 EDT
*** Bug 629385 has been marked as a duplicate of this bug. ***
Comment 5 Chuck Ebbert 2010-09-02 13:27:55 EDT
Peter, do you have any idea what might be causing this?
Comment 6 Dennis Appelon Nielsen 2010-09-02 14:58:43 EDT
Created attachment 915148 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 7 Peter Hutterer 2010-09-02 18:16:55 EDT
if X comes up normally and you plug the wacom device in, does it crash?

if so, please attach your Xorg.log file with the backtrace and what wacom tablet you're using. Thanks.
Comment 8 Stephen Haffly 2010-09-02 19:22:14 EDT
I just tried plugging in the Wacom tablet.  It did not crash.  It is a Graphire 3, Model CTE-630 (Graphite) (small print: CTE-630/G)

I will attach my Xorg.0.log file, even though it did not crash.
Comment 9 Stephen Haffly 2010-09-02 19:23:26 EDT
Created attachment 442748 [details]
Xorg.0.log file
Comment 10 Dennis Appelon Nielsen 2010-09-03 01:55:43 EDT
If I unplug my Wacom and Power Cycle, and then login when Gnome comes up, and then connect the wacome it works like a charm, but even after this trick, if I reboot with the wacome attached it goes cold again
Comment 11 Peter Hutterer 2010-09-03 02:49:06 EDT
weird. not quite sure how to debug this other than try runlevel 3 without graphical bootsplash and see how far you get before it hangs. does that work at all?
Comment 12 Stephen Haffly 2010-09-03 09:43:54 EDT
Created attachment 442907 [details]
Picture of screen just before blanking

The things I tried:

go through configuration and remove all vestiges of proprietary nvidia drivers, ensuring I was running nouveau.

result:  freeze

change to runlevel 3:

successfully boot to login screen.  Successfully login (either root or user)

issue "startx" command:

result:  freeze

Since it did not seem to be the nvidia drivers, I have since put them back on my system so that I could use the compiz effects.
Comment 13 Chuck Ebbert 2010-09-04 08:52:43 EDT
(In reply to comment #12)
> Created attachment 442907 [details]
> Picture of screen just before blanking
> 

So Xorg prints out the names of the config directories it's using, then locks solid. Do you have any custom configurations in any of those directories?
Comment 14 Stephen Haffly 2010-09-04 09:11:35 EDT
Not that I know of other than the xorg.conf that was made when I installed the nvidia driver.

# Xorg configuration created by livna-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib64/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
EndSection

Section "InputDevice"

# keyboard added by system-config-display
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105+inet"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection
Comment 15 Daniel Belton 2010-09-04 12:48:30 EDT
I am having the same issue as well since the kernel 2.34.6-47 update. worked fine in 2.34.3-37.

It seems to be a problem that is preventing Xserver from starting. I can ssh into the machine fine, and it only happens when the wacom tablet is plugged in during bootup. I can unplug the wacom tablet, boot, then after Xserver comes up, I can plug in the wacom tablet and it works fine. 

I was able to grab the following from my /var/log/messages:

Sep  4 09:48:24 tower10 libvirtd: 09:48:24.423: warning : lxcStartup:1908 : Unable to create cgroup for driver: No such device or address
Sep  4 09:48:31 tower10 kdm[1691]: X server startup timeout, terminating
Sep  4 09:49:01 tower10 kdm[1691]: X server termination timeout, killing
Sep  4 09:49:02 tower10 kdm[1691]: X server for display :0 cannot be started, session disabled
Sep  4 09:51:16 tower10 ntpd[1626]: 0.0.0.0 c61c 0c clock_step +0.426001 s
Sep  4 09:51:17 tower10 ntpd[1626]: 0.0.0.0 c614 04 freq_mode
Sep  4 09:51:18 tower10 ntpd[1626]: 0.0.0.0 c618 08 no_sys_peer
Sep  4 09:51:21 tower10 kernel: INFO: task khubd:28 blocked for more than 120 seconds.
Sep  4 09:51:21 tower10 kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Sep  4 09:51:21 tower10 kernel: khubd         D 0000000d     0    28      2 0x00000000
Sep  4 09:51:21 tower10 kernel: f718fd18 00000046 7f9f823d 0000000d c0a7ed40 c0a7ed40 c0a7ed40 c0a7ed40
Sep  4 09:51:21 tower10 kernel: f70f68ac c0a7ed40 c0a7ed40 00002ed1 00000000 f37f7200 0000000d f70f6600
Sep  4 09:51:21 tower10 kernel: 00000000 f6a14648 f70f6600 f6a1464c f718fd58 c07a15a6 f6a14658 00000000
Sep  4 09:51:21 tower10 kernel: Call Trace:
Sep  4 09:51:21 tower10 kernel: [<c07a15a6>] __mutex_lock_common+0x114/0x161
Sep  4 09:51:21 tower10 kernel: [<c04d0254>] ? __slab_free+0x18/0x199
Sep  4 09:51:21 tower10 kernel: [<c07a160a>] __mutex_lock_slowpath+0x17/0x1a
Sep  4 09:51:21 tower10 kernel: [<c07a16f9>] ? mutex_lock+0x30/0x3e
Sep  4 09:51:21 tower10 kernel: [<c07a16f9>] mutex_lock+0x30/0x3e
Sep  4 09:51:21 tower10 kernel: [<c06c08d0>] mousedev_disconnect+0x18/0x74
Sep  4 09:51:21 tower10 kernel: [<c06bdb13>] input_unregister_device+0xf4/0x16a
Sep  4 09:51:21 tower10 kernel: [<c06f5cb1>] hidinput_disconnect+0x2a/0x3e
Sep  4 09:51:21 tower10 kernel: [<c06f4579>] hid_disconnect+0x19/0x3d
Sep  4 09:51:21 tower10 kernel: [<c06f45ca>] hid_device_remove+0x2d/0x47
Sep  4 09:51:21 tower10 kernel: [<c0652640>] __device_release_driver+0x5c/0x9e
Sep  4 09:51:21 tower10 kernel: [<c065271f>] device_release_driver+0x1d/0x28
Sep  4 09:51:21 tower10 kernel: [<c0651b2c>] bus_remove_device+0x95/0xbe
Sep  4 09:51:21 tower10 kernel: [<c0650200>] device_del+0xf8/0x150
Sep  4 09:51:21 tower10 kernel: [<c06f4104>] hid_destroy_device+0x1f/0x3b
Sep  4 09:51:21 tower10 kernel: [<c06ffcf4>] usbhid_disconnect+0x31/0x3b
Sep  4 09:51:21 tower10 kernel: [<c06a19f9>] usb_unbind_interface+0x50/0xfb
Sep  4 09:51:21 tower10 kernel: [<c0652640>] __device_release_driver+0x5c/0x9e
Sep  4 09:51:21 tower10 kernel: [<c065271f>] device_release_driver+0x1d/0x28
Sep  4 09:51:21 tower10 kernel: [<c0651b2c>] bus_remove_device+0x95/0xbe
Sep  4 09:51:21 tower10 kernel: [<c0650200>] device_del+0xf8/0x150
Sep  4 09:51:21 tower10 kernel: [<c069ef47>] usb_disable_device+0xab/0x177
Sep  4 09:51:21 tower10 kernel: [<c0699289>] usb_disconnect+0xd0/0x180
Sep  4 09:51:21 tower10 kernel: [<c0699258>] usb_disconnect+0x9f/0x180
Sep  4 09:51:21 tower10 kernel: [<c069aece>] hub_thread+0x573/0x10f1
Sep  4 09:51:21 tower10 kernel: [<c0431e65>] ? __dequeue_entity+0x28/0x2c
Sep  4 09:51:21 tower10 kernel: [<c0454675>] ? autoremove_wake_function+0x0/0x34
Sep  4 09:51:21 tower10 kernel: [<c045430d>] kthread+0x64/0x69
Sep  4 09:51:21 tower10 kernel: [<c069a95b>] ? hub_thread+0x0/0x10f1
Sep  4 09:51:21 tower10 kernel: [<c069a95b>] ? hub_thread+0x0/0x10f1
Sep  4 09:51:21 tower10 kernel: [<c045430d>] ? kthread+0x64/0x69
Sep  4 09:51:21 tower10 kernel: [<c04542a9>] ? kthread+0x0/0x69
Sep  4 09:51:21 tower10 kernel: [<c040923e>] kernel_thread_helper+0x6/0x10
Sep  4 09:51:21 tower10 kernel: INFO: task gpm:1635 blocked for more than 120 seconds.
Sep  4 09:51:21 tower10 kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Sep  4 09:51:21 tower10 kernel: gpm           D 00000009     0  1635      1 0x00000080
Sep  4 09:51:21 tower10 kernel: f2aa7c60 00000086 55674ed8 00000009 c0a7ed40 c0a7ed40 c0a7ed40 c0a7ed40
Sep  4 09:51:21 tower10 kernel: f2a628ec c0a7ed40 c0a7ed40 004144db 00000000 00000000 00000009 f2a62640
Sep  4 09:51:21 tower10 kernel: 00000060 f614f7b4 f2a62640 f614f7b8 f2aa7ca0 c07a15a6 f614f7c4 00000000
Sep  4 09:51:21 tower10 kernel: Call Trace:
Sep  4 09:51:21 tower10 kernel: [<c07a15a6>] __mutex_lock_common+0x114/0x161
Sep  4 09:51:21 tower10 kernel: [<c07a160a>] __mutex_lock_slowpath+0x17/0x1a
Sep  4 09:51:21 tower10 kernel: [<c07a16f9>] ? mutex_lock+0x30/0x3e
Sep  4 09:51:21 tower10 kernel: [<c07a16f9>] mutex_lock+0x30/0x3e
Sep  4 09:51:21 tower10 kernel: [<c069bc45>] ? usb_port_resume+0x1f9/0x498
Sep  4 09:51:21 tower10 kernel: [<f8633b5e>] wacom_resume+0x24/0x56 [wacom]
Sep  4 09:51:21 tower10 kernel: [<c06a0e68>] usb_resume_interface+0xb7/0x115
Sep  4 09:51:21 tower10 kernel: [<c06a0f7c>] usb_resume_both+0xb6/0xda
Sep  4 09:51:21 tower10 kernel: [<c06a0fc5>] usb_runtime_resume+0x25/0x34
Sep  4 09:51:21 tower10 kernel: [<c0657cd0>] __pm_runtime_resume+0x24c/0x379
Sep  4 09:51:21 tower10 kernel: [<c0657a09>] ? __pm_runtime_put+0x29/0x30
Sep  4 09:51:21 tower10 kernel: [<c0657c15>] __pm_runtime_resume+0x191/0x379
Sep  4 09:51:21 tower10 kernel: [<c065794b>] ? __pm_runtime_idle+0x157/0x16f
Sep  4 09:51:21 tower10 kernel: [<c0657e64>] pm_runtime_resume+0x1f/0x32
Sep  4 09:51:21 tower10 kernel: [<c0657e8f>] __pm_runtime_get+0x18/0x21
Sep  4 09:51:21 tower10 kernel: [<c06a1462>] usb_autopm_get_interface+0x1c/0x40
Sep  4 09:51:21 tower10 kernel: [<f86343b7>] wacom_open+0x34/0x79 [wacom]
Sep  4 09:51:21 tower10 kernel: [<c06bd827>] input_open_device+0x5b/0x87
Sep  4 09:51:21 tower10 kernel: [<c06bfe5e>] mousedev_open_device+0xa1/0xb8
Sep  4 09:51:21 tower10 kernel: [<c06bfe0f>] mousedev_open_device+0x52/0xb8
Sep  4 09:51:21 tower10 kernel: [<c06c0a39>] mousedev_open+0x10d/0x144
Sep  4 09:51:21 tower10 kernel: [<c06bccd5>] input_open_file+0x8e/0xde
Sep  4 09:51:21 tower10 kernel: [<c04dc80c>] chrdev_open+0xf1/0x10e
Sep  4 09:51:21 tower10 kernel: [<c04d89a9>] __dentry_open+0x147/0x237
Sep  4 09:51:21 tower10 kernel: [<c04d8b3c>] nameidata_to_filp+0x31/0x45
Sep  4 09:51:21 tower10 kernel: [<c04dc71b>] ? chrdev_open+0x0/0x10e
Sep  4 09:51:21 tower10 kernel: [<c04e2717>] do_last+0x394/0x4a1
Sep  4 09:51:21 tower10 kernel: [<c04e3ccf>] do_filp_open+0x19c/0x43a
Sep  4 09:51:21 tower10 kernel: [<c05b45a0>] ? might_fault+0x1e/0x20
Sep  4 09:51:21 tower10 kernel: [<c04d875d>] do_sys_open+0x4d/0xe4
Sep  4 09:51:21 tower10 kernel: [<c04d8840>] sys_open+0x23/0x2b
Sep  4 09:51:21 tower10 kernel: [<c07a2614>] syscall_call+0x7/0xb
Comment 16 Chuck Ebbert 2010-09-07 12:24:35 EDT
(In reply to comment #15)
> I am having the same issue as well since the kernel 2.34.6-47 update. worked
> fine in 2.34.3-37.
> 

In your case it looks like gpm and khubd are deadlocking trying to obtain a mutex. You could try disabling the gpm service or even erasing the package and see if that helps. It doesn't look like it's even installed by default anymore.
Comment 17 Peter Hutterer 2010-09-07 18:13:12 EDT
*** Bug 630909 has been marked as a duplicate of this bug. ***
Comment 18 Daniel Belton 2010-09-08 01:41:50 EDT
yes, and I could disable the new kernel as well, since that is a more viable option than disabling something that I use, and the old kernel works flawlessly with gpm enabled. 

For now, I am booting with the wacom tablet unplugged, then plugging it in after the Xserver comes up. Then I have full use of everything. 

I did try disabling gpm after reading your response, though. I still get the same message from khubd and still the Xserver won't start if the wacom tablet is plugged in. Works fine if the wacom tablet is unplugged, and I can plug it in once Xserver comes up and it works fine.
Comment 19 Daniel Belton 2010-09-08 14:30:09 EDT
Just upgraded to the 2.6.34.6-54 kernel and this bug still persists. I get the above errors PLUS now I get more errors over and over in my messages log...

usb 8-1 is where my wacom tablet is plugged in. I disconnected it, and get these messages. there are no devices plugged into usb 7-1.

Sep  8 13:08:40 tower10 libvirtd: 13:08:40.684: warning : qemudStartup:1641 : Unable to create cgroup for driver: No such device or address
Sep  8 13:08:41 tower10 kernel: lo: Disabled Privacy Extensions
Sep  8 13:08:41 tower10 libvirtd: 13:08:41.532: warning : lxcStartup:1908 : Unable to create cgroup for driver: No such device or address
Sep  8 13:08:49 tower10 kdm[1666]: X server startup timeout, terminating
Sep  8 13:09:01 tower10 kernel: usb 8-1: USB disconnect, address 2
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot disable port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot disable port 1 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 3 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 3 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 3 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 3 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot reset port 3 (err = -71)
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: Cannot enable port 3.  Maybe the USB cable is bad?
Sep  8 13:09:10 tower10 kernel: hub 7-1:1.0: cannot disable port 3 (err = -71)
Comment 20 Domenico Ferrari 2010-09-11 05:08:11 EDT
Same problem with Graphire 4 and kernel 2.6.34.6-xx. Here's my lspci and lsusb output, if can help.
No lock with kernel 2.6.33.6-147.2.4.fc13.i686.

00:00.0 Host bridge: VIA Technologies, Inc. PT880 Ultra/PT894 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. PT894 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. PT894 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. PT894 Host Bridge
00:00.5 PIC: VIA Technologies, Inc. PT894 I/O APIC Interrupt Controller
00:00.7 Host bridge: VIA Technologies, Inc. PT894 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:09.0 USB Controller: NEC Corporation USB (rev 43)
00:09.1 USB Controller: NEC Corporation USB (rev 43)
00:09.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
00:0a.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)

Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 056a:0015 Wacom Co., Ltd 
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Bus 002 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Comment 21 Chuck Ebbert 2010-09-13 16:47:20 EDT
(In reply to comment #18)
 
> I did try disabling gpm after reading your response, though. I still get the
> same message from khubd and still the Xserver won't start if the wacom tablet
> is plugged in.

khubd is still deadlocking with gpm even though gpm is no longer running? Or is it deadlocking with some other process now?
Comment 22 Daniel Belton 2010-09-14 11:30:30 EDT
I assume it was still deadlocking with gpm. For some reason, even when I disabled gpm, I would still get that message from kdm but it would continue to boot (unless the wacom tablet is plugged in). I uninstalled gpm and the message disappeared (but X still will not start if the wacom tablet is plugged in). I have no problems booting when the wacom tablet is unplugged. I wouldn't get the deadlocking problem if the wacom tablet was unplugged, either (no messages from gpm or kdm).

I didn't get any of these messages in the 2.34.3-37 kernel (boots fine with the wacom tablet plugged in), but get them in the 2.34.6-47 and 2.6.34.6-54 kernels (neither boots with the wacom tablet plugged in, but will boot if tablet unplugged).

And as I have mentioned, it's not a kernel panic. Just that the Xserver doesn't start if the wacom tablet is plugged in at boot time. I can ssh into the box and do anything I wish that way. 

I am going to try booting without the tablet, when X comes up, plug in the tablet and then restart X and see what happens. Post back the results in a minute.
Comment 23 Daniel Belton 2010-09-14 11:35:39 EDT
Ok, I booted up without the wacom tablet and X started fine. Plugged in the tablet, and it worked fine, no problems. Restarted X (without rebooting) and X started fine with the tablet plugged in. 

When it reboots, X will not start with the tablet plugged in, but just restarting X it works fine even with the tablet plugged in.
Comment 24 Sinan H 2010-09-14 14:23:23 EDT
I'm hit quite bad with this: i've netinstalled F13 on a wacom touchscreen laptop (hp tx2500), and as the netinstall ends up with 2.6.34.6-54 as the only kernel and as I obviously cannot unplug the touchscreen, its impossible to boot properly in a X session. 
Im still looking for kernel{-devel,-headers}-2.6.33.8-149.fc13.x86_64.rpm or 2.34.3-37 but was unable to find any left around...
Comment 25 Chuck Ebbert 2010-09-14 18:59:19 EDT
Should be fixed in 2.6.34.7-56
Comment 26 Chuck Ebbert 2010-09-14 19:00:44 EDT
(In reply to comment #24)
> Im still looking for kernel{-devel,-headers}-2.6.33.8-149.fc13.x86_64.rpm or
> 2.34.3-37 but was unable to find any left around...

http://koji.fedoraproject.org/koji/buildinfo?buildID=190700
Comment 27 Fedora Update System 2010-09-15 01:30:34 EDT
kernel-2.6.34.7-56.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/kernel-2.6.34.7-56.fc13
Comment 28 Fedora Update System 2010-09-17 14:29:36 EDT
kernel-2.6.34.7-56.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kernel-2.6.34.7-56.fc13
Comment 29 Daniel Belton 2010-09-17 19:41:30 EDT
I can confirm that the 2.6.34.7-56 kernel fixes the problem booting with the wacom tablet plugged in. Also, I no longer get the deadlock with gpm and khubd, either.
Comment 30 Stephen Haffly 2010-09-17 20:56:32 EDT
However, for me, it does not fix the problem.  I first tried and got the same black screen.  I thought that it might have something to do with it being just the kernel updated, so I checked the boot parameters, and saw that nouveau was blacklisted (probably to do with there not being the other files needed for akmod-nvidia to build the kmod it needs, so with nouveau blacklisted, it did not have a suitable driver.

I removed the entries in the kernel boot line and tried again. Unfortunately, with the Wacom tablet plugged in, it showed almost the same behavior.  This time, the system went to a black screen, but I could see the drive activity light blink briefly every few seconds.  I tried pressing the Num Lock and Caps Lock keys. When I did so, the LEDs for them were blinking.  After a little bit, they stopped blinking, and I had keyboard control.

From that point, I could execute a CTRL-ALT-F2 to get to a different screen where I could log in as root and execute a proper shut-down.

I'm back to the previous kernel, at least until this one or its successor is released so I can have the associated kernel files with it.
Comment 31 Stephen Haffly 2010-09-18 08:23:51 EDT
I looked at some log files, and this is the Xorg.0.log.old file contents:

[    63.846] 
X.Org X Server 1.8.2
Release Date: 2010-07-01
[    63.846] X Protocol Version 11, Revision 0
[    63.846] Build Operating System: x86-16 2.6.32-44.el6.x86_64 
[    63.846] Current Operating System: Linux emerald.hhome 2.6.34.7-56.fc13.x86_64 #1 SMP Wed Sep 15 03:36:55 UTC 2010 x86_64
[    63.846] Kernel command line: ro root=UUID=0c70fe4a-8a59-43fd-b0e9-5c54d73369c9 rhgb quiet SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us vga=0x31b nouveau.modeset=0 rdblacklist=nouveau
[    63.847] Build Date: 03 August 2010  05:10:46AM
[    63.847] Build ID: xorg-x11-server 1.8.2-3.fc13 
[    63.847] Current version of pixman: 0.18.0
[    63.847] 	Before reporting problems, check http://bodhi.fedoraproject.org/
	to make sure that you have the latest version.
[    63.847] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    63.847] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 17 17:37:25 2010
[    63.847] (==) Using config file: "/etc/X11/xorg.conf"
[    63.847] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    63.847] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    63.848] (==) ServerLayout "single head configuration"
[    63.848] (**) |-->Screen "Screen0" (0)
[    63.848] (**) |   |-->Monitor "<default monitor>"
[    63.848] (**) |   |-->Device "Videocard0"
[    63.848] (==) No monitor specified for screen "Screen0".
	Using a default monitor configuration.
[    63.848] (**) |-->Input Device "Keyboard0"
[    63.848] (**) Option "AIGLX" "on"
[    63.848] (==) Automatically adding devices
[    63.848] (==) Automatically enabling devices
[    63.848] (==) FontPath set to:
	catalogue:/etc/X11/fontpath.d,
	built-ins
[    63.848] (**) ModulePath set to "/usr/lib64/xorg/modules"
[    63.848] (**) Extension "Composite" is enabled
[    63.848] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    63.849] (II) 
***************************************************************
***************************************************************
** Fedora switched to udev-based device detection with       **
** xorg-x11-server-1.7.99.901-1. Custom HAL configuration    **
** stored in /etc/hal/fdi/policy will not be seen by this    **
** server version. If you have such configuration you will   **
** need to update it to the new format.                      **
** For more information, see the Fedora wiki page            **
** https://fedoraproject.org/wiki/Input_device_configuration **
***************************************************************
***************************************************************
[    63.849] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    63.849] (WW) Disabling Keyboard0
[    63.849] (II) Loader magic: 0x7cfa40
[    63.849] (II) Module ABI versions:
[    63.849] 	X.Org ANSI C Emulation: 0.4
[    63.849] 	X.Org Video Driver: 7.0
[    63.849] 	X.Org XInput driver : 9.0
[    63.849] 	X.Org Server Extension : 3.0
[    63.860] (--) PCI: (0:0:1:3) 10de:0753:1043:82e2 nVidia Corporation MCP78S [GeForce 8200] Co-Processor rev 162, Mem @ 0xf9e80000/524288, BIOS @ 0x????????/65536
[    63.860] (--) PCI:*(0:2:0:0) 10de:0392:196e:033c nVidia Corporation G73 [GeForce 7600 GS] rev 161, Mem @ 0xfb000000/16777216, 0xd0000000/268435456, 0xfa000000/16777216, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
[    63.860] (II) LoadModule: "extmod"
[    63.861] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[    63.861] (II) Module extmod: vendor="X.Org Foundation"
[    63.861] 	compiled for 1.8.2, module version = 1.0.0
[    63.861] 	Module class: X.Org Server Extension
[    63.861] 	ABI class: X.Org Server Extension, version 3.0
[    63.861] (II) Loading extension SELinux
[    63.861] (II) Loading extension MIT-SCREEN-SAVER
[    63.861] (II) Loading extension XFree86-VidModeExtension
[    63.861] (II) Loading extension XFree86-DGA
[    63.861] (II) Loading extension DPMS
[    63.861] (II) Loading extension XVideo
[    63.861] (II) Loading extension XVideo-MotionCompensation
[    63.862] (II) Loading extension X-Resource
[    63.862] (II) LoadModule: "dbe"
[    63.862] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[    63.862] (II) Module dbe: vendor="X.Org Foundation"
[    63.862] 	compiled for 1.8.2, module version = 1.0.0
[    63.862] 	Module class: X.Org Server Extension
[    63.862] 	ABI class: X.Org Server Extension, version 3.0
[    63.862] (II) Loading extension DOUBLE-BUFFER
[    63.862] (II) LoadModule: "glx"
[    63.863] (II) Loading /usr/lib64/xorg/modules/extensions/nvidia/libglx.so
[    63.866] (II) Module glx: vendor="NVIDIA Corporation"
[    63.866] 	compiled for 4.0.2, module version = 1.0.0
[    63.866] 	Module class: X.Org Server Extension
[    63.867] (II) NVIDIA GLX Module  256.53  Fri Aug 27 20:50:26 PDT 2010
[    63.867] (II) Loading extension GLX
[    63.867] (II) LoadModule: "record"
[    63.867] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[    63.867] (II) Module record: vendor="X.Org Foundation"
[    63.867] 	compiled for 1.8.2, module version = 1.13.0
[    63.867] 	Module class: X.Org Server Extension
[    63.867] 	ABI class: X.Org Server Extension, version 3.0
[    63.867] (II) Loading extension RECORD
[    63.867] (II) LoadModule: "dri"
[    63.868] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[    63.868] (II) Module dri: vendor="X.Org Foundation"
[    63.868] 	compiled for 1.8.2, module version = 1.0.0
[    63.868] 	ABI class: X.Org Server Extension, version 3.0
[    63.868] (II) Loading extension XFree86-DRI
[    63.868] (II) LoadModule: "dri2"
[    63.869] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[    63.869] (II) Module dri2: vendor="X.Org Foundation"
[    63.869] 	compiled for 1.8.2, module version = 1.2.0
[    63.869] 	ABI class: X.Org Server Extension, version 3.0
[    63.869] (II) Loading extension DRI2
[    63.869] (II) LoadModule: "nouveau"
[    63.870] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[    63.870] (II) Module nouveau: vendor="X.Org Foundation"
[    63.870] 	compiled for 1.8.2, module version = 0.0.16
[    63.870] 	Module class: X.Org Video Driver
[    63.870] 	ABI class: X.Org Video Driver, version 7.0
[    63.870] (II) NOUVEAU driver 
[    63.870] (II) NOUVEAU driver for NVIDIA chipset families :
[    63.870] 	RIVA TNT    (NV04)
[    63.870] 	RIVA TNT2   (NV05)
[    63.870] 	GeForce 256 (NV10)
[    63.870] 	GeForce 2   (NV11, NV15)
[    63.870] 	GeForce 4MX (NV17, NV18)
[    63.870] 	GeForce 3   (NV20)
[    63.871] 	GeForce 4Ti (NV25, NV28)
[    63.871] 	GeForce FX  (NV3x)
[    63.871] 	GeForce 6   (NV4x)
[    63.871] 	GeForce 7   (G7x)
[    63.871] 	GeForce 8   (G8x)
[    63.871] (--) using VT number 7

[    63.896] (II) Primary Device is: PCI 02@00:00:0
[    63.896] drmOpenDevice: node name is /dev/dri/card0
[    63.912] drmOpenByBusid: Searching for BusID pci:0000:02:00.0
[    63.912] drmOpenDevice: node name is /dev/dri/card0
[    63.925] drmOpenByBusid: drmOpenMinor returns -1
[    63.925] drmOpenDevice: node name is /dev/dri/card1
[    63.938] drmOpenByBusid: drmOpenMinor returns -1
[    63.938] drmOpenDevice: node name is /dev/dri/card2
[    63.950] drmOpenByBusid: drmOpenMinor returns -1
[    63.950] drmOpenDevice: node name is /dev/dri/card3
[    63.963] drmOpenByBusid: drmOpenMinor returns -1
[    63.963] drmOpenDevice: node name is /dev/dri/card4
[    63.976] drmOpenByBusid: drmOpenMinor returns -1
[    63.976] drmOpenDevice: node name is /dev/dri/card5
[    63.988] drmOpenByBusid: drmOpenMinor returns -1
[    63.988] drmOpenDevice: node name is /dev/dri/card6
[    64.001] drmOpenByBusid: drmOpenMinor returns -1
[    64.001] drmOpenDevice: node name is /dev/dri/card7
[    64.014] drmOpenByBusid: drmOpenMinor returns -1
[    64.014] drmOpenDevice: node name is /dev/dri/card8
[    64.027] drmOpenByBusid: drmOpenMinor returns -1
[    64.027] drmOpenDevice: node name is /dev/dri/card9
[    64.039] drmOpenByBusid: drmOpenMinor returns -1
[    64.039] drmOpenDevice: node name is /dev/dri/card10
[    64.052] drmOpenByBusid: drmOpenMinor returns -1
[    64.052] drmOpenDevice: node name is /dev/dri/card11
[    64.065] drmOpenByBusid: drmOpenMinor returns -1
[    64.065] drmOpenDevice: node name is /dev/dri/card12
[    64.078] drmOpenByBusid: drmOpenMinor returns -1
[    64.078] drmOpenDevice: node name is /dev/dri/card13
[    64.090] drmOpenByBusid: drmOpenMinor returns -1
[    64.090] drmOpenDevice: node name is /dev/dri/card14
[    64.103] drmOpenByBusid: drmOpenMinor returns -1
[    64.103] drmOpenDevice: node name is /dev/dri/card15
[    64.116] drmOpenByBusid: drmOpenMinor returns -1
[    64.116] drmOpenDevice: node name is /dev/dri/card0
[    64.132] drmOpenDevice: node name is /dev/dri/card0
[    64.144] drmOpenDevice: node name is /dev/dri/card1
[    64.157] drmOpenDevice: node name is /dev/dri/card2
[    64.170] drmOpenDevice: node name is /dev/dri/card3
[    64.183] drmOpenDevice: node name is /dev/dri/card4
[    64.195] drmOpenDevice: node name is /dev/dri/card5
[    64.208] drmOpenDevice: node name is /dev/dri/card6
[    64.220] drmOpenDevice: node name is /dev/dri/card7
[    64.232] drmOpenDevice: node name is /dev/dri/card8
[    64.245] drmOpenDevice: node name is /dev/dri/card9
[    64.257] drmOpenDevice: node name is /dev/dri/card10
[    64.270] drmOpenDevice: node name is /dev/dri/card11
[    64.283] drmOpenDevice: node name is /dev/dri/card12
[    64.295] drmOpenDevice: node name is /dev/dri/card13
[    64.308] drmOpenDevice: node name is /dev/dri/card14
[    64.321] drmOpenDevice: node name is /dev/dri/card15
[    64.334] (EE) [drm] failed to open device
[    64.334] (EE) No devices detected.
[    64.334] 
Fatal server error:
[    64.334] no screens found
[    64.334] 
Please consult the Fedora Project support 
	 at http://bodhi.fedoraproject.org/
 for help. 
[    64.334] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    64.334] 

The Xorg.0.log is from a subsequent boot with the previous kernel and Nvidia driver:

[    32.854] 
X.Org X Server 1.8.2
Release Date: 2010-07-01
[    32.854] X Protocol Version 11, Revision 0
[    32.854] Build Operating System: x86-16 2.6.32-44.el6.x86_64 
[    32.854] Current Operating System: Linux emerald.hhome 2.6.34.6-54.fc13.x86_64 #1 SMP Sun Sep 5 17:16:27 UTC 2010 x86_64
[    32.855] Kernel command line: ro root=UUID=0c70fe4a-8a59-43fd-b0e9-5c54d73369c9 rhgb quiet SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us vga=0x31b nouveau.modeset=0 rdblacklist=nouveau
[    32.855] Build Date: 03 August 2010  05:10:46AM
[    32.855] Build ID: xorg-x11-server 1.8.2-3.fc13 
[    32.855] Current version of pixman: 0.18.0
[    32.855] 	Before reporting problems, check http://bodhi.fedoraproject.org/
	to make sure that you have the latest version.
[    32.855] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    32.855] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 17 17:39:48 2010
[    32.856] (==) Using config file: "/etc/X11/xorg.conf"
[    32.856] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    32.856] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    32.857] (==) ServerLayout "single head configuration"
[    32.857] (**) |-->Screen "Screen0" (0)
[    32.857] (**) |   |-->Monitor "<default monitor>"
[    32.857] (**) |   |-->Device "Videocard0"
[    32.857] (==) No monitor specified for screen "Screen0".
	Using a default monitor configuration.
[    32.857] (**) |-->Input Device "Keyboard0"
[    32.857] (**) Option "AIGLX" "on"
[    32.857] (==) Automatically adding devices
[    32.857] (==) Automatically enabling devices
[    32.857] (==) FontPath set to:
	catalogue:/etc/X11/fontpath.d,
	built-ins
[    32.857] (**) ModulePath set to "/usr/lib64/xorg/modules/extensions/nvidia,/usr/lib64/xorg/modules"
[    32.857] (**) Extension "Composite" is enabled
[    32.857] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    32.857] (II) 
***************************************************************
***************************************************************
** Fedora switched to udev-based device detection with       **
** xorg-x11-server-1.7.99.901-1. Custom HAL configuration    **
** stored in /etc/hal/fdi/policy will not be seen by this    **
** server version. If you have such configuration you will   **
** need to update it to the new format.                      **
** For more information, see the Fedora wiki page            **
** https://fedoraproject.org/wiki/Input_device_configuration **
***************************************************************
***************************************************************
[    32.857] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    32.857] (WW) Disabling Keyboard0
[    32.857] (II) Loader magic: 0x7cfa40
[    32.857] (II) Module ABI versions:
[    32.858] 	X.Org ANSI C Emulation: 0.4
[    32.858] 	X.Org Video Driver: 7.0
[    32.858] 	X.Org XInput driver : 9.0
[    32.858] 	X.Org Server Extension : 3.0
[    32.869] (--) PCI: (0:0:1:3) 10de:0753:1043:82e2 nVidia Corporation MCP78S [GeForce 8200] Co-Processor rev 162, Mem @ 0xf9e80000/524288, BIOS @ 0x????????/65536
[    32.869] (--) PCI:*(0:2:0:0) 10de:0392:196e:033c nVidia Corporation G73 [GeForce 7600 GS] rev 161, Mem @ 0xfb000000/16777216, 0xd0000000/268435456, 0xfa000000/16777216, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
[    32.870] (II) LoadModule: "extmod"
[    32.977] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[    32.978] (II) Module extmod: vendor="X.Org Foundation"
[    32.978] 	compiled for 1.8.2, module version = 1.0.0
[    32.978] 	Module class: X.Org Server Extension
[    32.978] 	ABI class: X.Org Server Extension, version 3.0
[    32.978] (II) Loading extension SELinux
[    32.978] (II) Loading extension MIT-SCREEN-SAVER
[    32.978] (II) Loading extension XFree86-VidModeExtension
[    32.978] (II) Loading extension XFree86-DGA
[    32.978] (II) Loading extension DPMS
[    32.978] (II) Loading extension XVideo
[    32.978] (II) Loading extension XVideo-MotionCompensation
[    32.978] (II) Loading extension X-Resource
[    32.978] (II) LoadModule: "dbe"
[    32.978] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[    32.979] (II) Module dbe: vendor="X.Org Foundation"
[    32.979] 	compiled for 1.8.2, module version = 1.0.0
[    32.979] 	Module class: X.Org Server Extension
[    32.979] 	ABI class: X.Org Server Extension, version 3.0
[    32.979] (II) Loading extension DOUBLE-BUFFER
[    32.979] (II) LoadModule: "glx"
[    32.979] (II) Loading /usr/lib64/xorg/modules/extensions/nvidia/libglx.so
[    33.116] (II) Module glx: vendor="NVIDIA Corporation"
[    33.116] 	compiled for 4.0.2, module version = 1.0.0
[    33.116] 	Module class: X.Org Server Extension
[    33.116] (II) NVIDIA GLX Module  256.53  Fri Aug 27 20:50:26 PDT 2010
[    33.116] (II) Loading extension GLX
[    33.116] (II) LoadModule: "record"
[    33.117] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[    33.117] (II) Module record: vendor="X.Org Foundation"
[    33.117] 	compiled for 1.8.2, module version = 1.13.0
[    33.117] 	Module class: X.Org Server Extension
[    33.117] 	ABI class: X.Org Server Extension, version 3.0
[    33.117] (II) Loading extension RECORD
[    33.117] (II) LoadModule: "dri"
[    33.118] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[    33.118] (II) Module dri: vendor="X.Org Foundation"
[    33.118] 	compiled for 1.8.2, module version = 1.0.0
[    33.118] 	ABI class: X.Org Server Extension, version 3.0
[    33.118] (II) Loading extension XFree86-DRI
[    33.118] (II) LoadModule: "dri2"
[    33.119] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[    33.119] (II) Module dri2: vendor="X.Org Foundation"
[    33.119] 	compiled for 1.8.2, module version = 1.2.0
[    33.119] 	ABI class: X.Org Server Extension, version 3.0
[    33.119] (II) Loading extension DRI2
[    33.119] (II) LoadModule: "nvidia"
[    33.126] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    33.197] (II) Module nvidia: vendor="NVIDIA Corporation"
[    33.222] 	compiled for 4.0.2, module version = 1.0.0
[    33.222] 	Module class: X.Org Video Driver
[    33.283] (II) NVIDIA dlloader X Driver  256.53  Fri Aug 27 20:29:45 PDT 2010
[    33.283] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    33.283] (++) using VT number 1

[    33.285] (II) Primary Device is: PCI 02@00:00:0
[    33.285] (II) Loading sub module "fb"
[    33.285] (II) LoadModule: "fb"
[    33.286] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    33.309] (II) Module fb: vendor="X.Org Foundation"
[    33.309] 	compiled for 1.8.2, module version = 1.0.0
[    33.309] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    33.309] (II) Loading sub module "wfb"
[    33.309] (II) LoadModule: "wfb"
[    33.334] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    33.363] (II) Module wfb: vendor="X.Org Foundation"
[    33.363] 	compiled for 1.8.2, module version = 1.0.0
[    33.363] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    33.364] (II) Loading sub module "ramdac"
[    33.364] (II) LoadModule: "ramdac"
[    33.364] (II) Module "ramdac" already built-in
[    33.417] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    33.417] (==) NVIDIA(0): RGB weight 888
[    33.417] (==) NVIDIA(0): Default visual is TrueColor
[    33.417] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    33.417] (**) NVIDIA(0): Enabling RENDER acceleration
[    33.417] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[    33.417] (II) NVIDIA(0):     enabled.
[    34.698] (II) NVIDIA(0): NVIDIA GPU GeForce 7600 GS (G73) at PCI:2:0:0 (GPU-0)
[    34.698] (--) NVIDIA(0): Memory: 524288 kBytes
[    34.698] (--) NVIDIA(0): VideoBIOS: 05.73.22.33.51
[    34.698] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    34.698] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[    34.698] (--) NVIDIA(0): Connected display device(s) on GeForce 7600 GS at PCI:2:0:0:
[    34.698] (--) NVIDIA(0):     HP w22 (DFP-0)
[    34.698] (--) NVIDIA(0): HP w22 (DFP-0): 330.0 MHz maximum pixel clock
[    34.698] (--) NVIDIA(0): HP w22 (DFP-0): Internal Dual Link TMDS
[    34.699] (II) NVIDIA(0): Assigned Display Device: DFP-0
[    34.699] (==) NVIDIA(0): 
[    34.699] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    34.699] (==) NVIDIA(0):     will be used as the requested mode.
[    34.699] (==) NVIDIA(0): 
[    34.699] (II) NVIDIA(0): Validated modes:
[    34.699] (II) NVIDIA(0):     "nvidia-auto-select"
[    34.699] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
[    34.701] (--) NVIDIA(0): DPI set to (90, 88); computed from "UseEdidDpi" X config
[    34.701] (--) NVIDIA(0):     option
[    34.701] (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
[    34.701] (--) Depth 24 pixmap format is 32 bpp
[    34.720] (II) NVIDIA(0): Initialized GPU GART.
[    34.750] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[    34.904] (II) Loading extension NV-GLX
[    34.944] (II) NVIDIA(0): Initialized OpenGL Acceleration
[    34.956] (==) NVIDIA(0): Disabling shared memory pixmaps
[    34.956] (II) NVIDIA(0): Initialized X Rendering Acceleration
[    34.956] (==) NVIDIA(0): Backing store disabled
[    34.956] (==) NVIDIA(0): Silken mouse enabled
[    34.956] (==) NVIDIA(0): DPMS enabled
[    34.956] (II) Loading extension NV-CONTROL
[    34.957] (II) Loading extension XINERAMA
[    34.957] (II) Loading sub module "dri2"
[    34.957] (II) LoadModule: "dri2"
[    34.957] (II) Reloading /usr/lib64/xorg/modules/extensions/libdri2.so
[    34.957] (II) NVIDIA(0): [DRI2] Setup complete
[    34.957] (==) RandR enabled
[    34.957] (II) Initializing built-in extension Generic Event Extension
[    34.957] (II) Initializing built-in extension SHAPE
[    34.957] (II) Initializing built-in extension MIT-SHM
[    34.957] (II) Initializing built-in extension XInputExtension
[    34.957] (II) Initializing built-in extension XTEST
[    34.957] (II) Initializing built-in extension BIG-REQUESTS
[    34.957] (II) Initializing built-in extension SYNC
[    34.957] (II) Initializing built-in extension XKEYBOARD
[    34.957] (II) Initializing built-in extension XC-MISC
[    34.957] (II) Initializing built-in extension XINERAMA
[    34.957] (II) Initializing built-in extension XFIXES
[    34.957] (II) Initializing built-in extension RENDER
[    34.957] (II) Initializing built-in extension RANDR
[    34.957] (II) Initializing built-in extension COMPOSITE
[    34.957] (II) Initializing built-in extension DAMAGE
[    34.958] (II) SELinux: Disabled by boolean
[    34.960] (II) Initializing extension GLX
[    35.614] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    35.614] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    35.614] (**) Power Button: Applying InputClass "system-setup-keyboard"
[    35.614] (II) LoadModule: "evdev"
[    35.615] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    35.620] (II) Module evdev: vendor="X.Org Foundation"
[    35.620] 	compiled for 1.7.99.901, module version = 2.4.0
[    35.620] 	Module class: X.Org XInput Driver
[    35.620] 	ABI class: X.Org XInput driver, version 9.0
[    35.620] (**) Power Button: always reports core events
[    35.620] (**) Power Button: Device: "/dev/input/event1"
[    35.639] (II) Power Button: Found keys
[    35.639] (II) Power Button: Configuring as keyboard
[    35.639] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    35.639] (**) Option "xkb_rules" "evdev"
[    35.639] (**) Option "xkb_model" "pc105+inet"
[    35.639] (**) Option "xkb_layout" "us"
[    35.639] (WW) Option "xkb_variant" requires an string value
[    35.639] (WW) Option "XkbVariant" requires an string value
[    35.639] (**) Option "xkb_options" "terminate:ctrl_alt_bksp,"
[    35.697] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    35.697] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    35.697] (**) Power Button: Applying InputClass "system-setup-keyboard"
[    35.697] (**) Power Button: always reports core events
[    35.697] (**) Power Button: Device: "/dev/input/event0"
[    35.703] (II) Power Button: Found keys
[    35.703] (II) Power Button: Configuring as keyboard
[    35.703] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    35.703] (**) Option "xkb_rules" "evdev"
[    35.703] (**) Option "xkb_model" "pc105+inet"
[    35.703] (**) Option "xkb_layout" "us"
[    35.703] (WW) Option "xkb_variant" requires an string value
[    35.703] (WW) Option "XkbVariant" requires an string value
[    35.703] (**) Option "xkb_options" "terminate:ctrl_alt_bksp,"
[    35.711] (II) config/udev: Adding input device zc3xx (/dev/input/event4)
[    35.711] (**) zc3xx: Applying InputClass "evdev keyboard catchall"
[    35.711] (**) zc3xx: Applying InputClass "system-setup-keyboard"
[    35.711] (**) zc3xx: always reports core events
[    35.711] (**) zc3xx: Device: "/dev/input/event4"
[    35.723] (II) zc3xx: Found keys
[    35.723] (II) zc3xx: Configuring as keyboard
[    35.723] (II) XINPUT: Adding extended input device "zc3xx" (type: KEYBOARD)
[    35.723] (**) Option "xkb_rules" "evdev"
[    35.723] (**) Option "xkb_model" "pc105+inet"
[    35.723] (**) Option "xkb_layout" "us"
[    35.723] (WW) Option "xkb_variant" requires an string value
[    35.723] (WW) Option "XkbVariant" requires an string value
[    35.723] (**) Option "xkb_options" "terminate:ctrl_alt_bksp,"
[    35.742] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[    35.742] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    35.742] (**) AT Translated Set 2 keyboard: Applying InputClass "system-setup-keyboard"
[    35.742] (**) AT Translated Set 2 keyboard: always reports core events
[    35.742] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[    35.749] (II) AT Translated Set 2 keyboard: Found keys
[    35.749] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[    35.749] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[    35.749] (**) Option "xkb_rules" "evdev"
[    35.749] (**) Option "xkb_model" "pc105+inet"
[    35.749] (**) Option "xkb_layout" "us"
[    35.749] (WW) Option "xkb_variant" requires an string value
[    35.749] (WW) Option "XkbVariant" requires an string value
[    35.749] (**) Option "xkb_options" "terminate:ctrl_alt_bksp,"
[    35.750] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/event3)
[    35.750] (**) PS/2 Generic Mouse: Applying InputClass "evdev pointer catchall"
[    35.750] (**) PS/2 Generic Mouse: always reports core events
[    35.750] (**) PS/2 Generic Mouse: Device: "/dev/input/event3"
[    35.757] (II) PS/2 Generic Mouse: Found 3 mouse buttons
[    35.757] (II) PS/2 Generic Mouse: Found relative axes
[    35.757] (II) PS/2 Generic Mouse: Found x and y relative axes
[    35.757] (II) PS/2 Generic Mouse: Configuring as mouse
[    35.757] (**) PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
[    35.757] (**) PS/2 Generic Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    35.757] (II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE)
[    35.757] (**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
[    35.757] (**) PS/2 Generic Mouse: (accel) acceleration profile 0
[    35.757] (**) PS/2 Generic Mouse: (accel) acceleration factor: 2.000
[    35.757] (**) PS/2 Generic Mouse: (accel) acceleration threshold: 4
[    35.757] (II) PS/2 Generic Mouse: initialized for relative axes.
[    35.758] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/mouse0)
[    35.758] (II) No input driver/identifier specified (ignoring)
Comment 32 Sinan H 2010-09-18 10:28:07 EDT
(In reply to comment #31)
Stephen: its not wacom related, you're still blacklisting nouveau:

> [    63.846] Kernel command line: ro
> root=UUID=0c70fe4a-8a59-43fd-b0e9-5c54d73369c9 rhgb quiet
> SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us vga=0x31b
> nouveau.modeset=0 rdblacklist=nouveau

get rid of nouveau.modeset=0 rdblacklist=nouveau from your grub. 
alternatively you can yum akmod-nvidia to build the kmod-nvidia yourself for 2.6.34.7-56.fc13 

on my side, wacom bug is fixed though akmod-catalyst doesn't build on 34.7.x86_64:
/tmp/akmodsbuild.1AeTiEsM/BUILD/catalyst- kmod-10.8/_kmod_build_2.6.34.7-56.fc13.x86_64/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.c:196: error: implicit declaration of function 'compat_alloc_user_space' 

it was OK on previous 2.6.34 & 33 kernels. akmod-nvidia builds.
does it deserve a bug on rpmfusion ?
Comment 33 Stephen Haffly 2010-09-18 11:00:56 EDT
Actually, I had removed the nouveau.modeset=0 rdblacklist=nouveau parameters, but it made no difference.  Although I could boot to a screen (without Compiz, Metacity only), if I tried it with the Wacom tablet plugged in, it still went to the black screen as I described above.
Comment 34 Nicholas Kudriavtsev 2010-09-18 15:48:30 EDT
2.6.34.7-56 kernel fixes the problem for me too.
Comment 35 Fedora Update System 2010-09-20 21:29:41 EDT
kernel-2.6.34.7-56.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 36 Daniel Belton 2010-09-21 14:30:48 EDT
I had no problem with akmod-nvidia building the kernel module as soon as I updated to the new kernel.

However, if you are trying to boot with nouveau and are using an xorg.conf file made for the nvidia driver, it's not going to work, either. 

I notice in your first xorg log that you are loading nouveau, but it still shows loading the nvidia glx module.
Comment 37 James 2010-09-27 00:05:31 EDT
I still got the same problem in the latest kernel 2.6.34.7.fc13.x86_64, black screen. Any ideas?

Note You need to log in before you can comment on or make changes to this bug.