Bug 62953 - inst cd not bootable from atapi device on promise controller
inst cd not bootable from atapi device on promise controller
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-08 08:10 EDT by Thomas M Steenholdt
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 10:39:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2002-04-08 08:10:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
The installation CD does not appear to be bootable, when inserted in ATAPI
Device attached to Promise Ultra133-TX2 adapter on system boot.
My other ATAPI device attached to motherboard controller boots from the CD just
fine. Just as a Windows Xp installation CD boots fine in the promise attached
device.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. RH 7.2.93 Media in ATAPI device on Promise Ultra133-TX2 controller
2. Boot System

	

Actual Results:  My already installed system started

Expected Results:  The RH installation should have started instead

Additional info:

According to Promise, they "don't allow booting from ATAPI devices". But like i
descriped above, my Windows Xp CD boots without any problems, so that can't be
entirely correct.
Comment 1 Michael Fulbright 2002-04-09 12:51:45 EDT
Did you Red Hat CD boot on any other systems, or if you move the CD to a
different IDE adapter?

If Promise says this is not supported then there is very little we can do.
Comment 2 Thomas M Steenholdt 2002-04-09 14:12:01 EDT
The CD boots fine on other systems or even when used in the exact same device,
but on another controller. 
I know, that if promise doesn't support booting from ATAPI devices, they are not
likely to be very helpful locating the problem. But it still puzzles me that the
Windows Xp CD does in fact boot from that device on that controller.

If you are unable to fix the problem, then I guess thats just too bad... But at
least now you know... a litte something to the "known problems" list.
Comment 3 David Balažic 2002-04-10 10:39:52 EDT
An idea :
 - windows NT4 CD is using a native ( non-emulation ) boot mode, maybe XP does 
the same
 - redhat CD uses a floppy-emulation boot mode
 - boot from the Promise card is controlled by the Promise BIOS
 - boot from the motherboard controller is controlled by the motherboard BIOS

Maybe the Promise BIOS supports native CD booting , but no emulation modes ?
Comment 4 Michael Fulbright 2002-04-10 12:37:07 EDT
Perhaps the Promise BIOS for that controller does not support the el Torrito
standard for booting from CDs.

In any case since this is documented by Promise to not work, and we are not
going to change our process from using el Torrito, I don't see this as an issue
we'll be addressing.
Comment 5 Thomas M Steenholdt 2002-04-10 13:32:34 EDT
At least now it's a know "problem" -  I'll get my Red Hat Linux installed anyway ;-)

Note You need to log in before you can comment on or make changes to this bug.