Bug 629580 - remove dependency on less
remove dependency on less
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gzip (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Vojtech Vitek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: FedoraServerTracker
  Show dependency treegraph
 
Reported: 2010-09-02 08:53 EDT by Daniel Mach
Modified: 2015-03-04 18:56 EST (History)
5 users (show)

See Also:
Fixed In Version: gzip-1.4-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-27 04:06:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2010-09-02 08:53:23 EDT
There are several gzip wrappers for another tools:
/usr/bin/zcmp
/usr/bin/zdiff
/usr/bin/zegrep
/usr/bin/zfgrep
/usr/bin/zforce
/usr/bin/zgrep
/usr/bin/zless
/usr/bin/zmore
/usr/bin/znew

The only one directly required by gzip package is less,
the others are not strictly required (scripts usually report "command not found").
Could you remove this dependency too?
Or is there a reason to keep it?
Comment 1 Karel Klíč 2010-09-06 10:43:24 EDT
> Could you remove this dependency too?

Yes, as it seems that less is needed only by the zless utility.
Comment 2 Karel Klíč 2010-09-06 11:03:43 EDT
I added the following comment to gzip.spec:
# Requires should not be added for gzip wrappers (eg. zdiff, zgrep,
# zless) of another tools, because gzip "extends" the tools by its
# wrappers much more than it "requires" them.

and removed the dependency on less.
Comment 3 Patrice Dumas 2010-09-06 11:23:11 EDT
This is not an acceptable solution for an integrated distribution.  Having an error message like "command not found" when running a command shipped is unacceptable, in my opinion.

Unless I missed something, the missing dependencies are
cmp
more
less
grep
diff

Maybe the problematic scripts could be moved to a sub-package.
Comment 4 Daniel Mach 2010-09-06 14:16:35 EDT
Another option is to move z* scripts outside gzip - to less, diffutils etc.
and also reverse dependencies.
Comment 5 Karel Klíč 2010-09-07 12:26:22 EDT
Patrice,
sure, a distribution with too little dependencies is difficult to use (because you must know a lot about what you are doing), but a distribution with too many dependencies is also difficult to use (too much space taken by the dependencies of basic packages, more difficult to provide custom-built packages, embedded installations; why do I need to install diff when I just want to gzip something?).

We really miss the "Extends:" RPM dependency type, it would be a perfect fit here, and it would allow a user/tool/spin to choose the appropriate action.

> Having an error message like "command not found" when running a command 
> shipped is unacceptable, in my opinion.
PackageKit-command-not-found plugin catches that and offers to install the missing package, doesn't it? I think it's installed by default. I'll try how it behaves on Rawhide.

Dan,
that solution seems to be a lot of work, because all those packages would need to download gzip upstream package, extract the script from that, and watch gzip upstream for updates. It also breaks the "stay close to upstream" Fedora principle.


For me it's ok to add all that dependencies if people really want it that way, but I can easily imagine a new RFE from the Server SIG in a month, asking me to remove them again.
Comment 6 Tomas Mraz 2010-11-02 16:10:12 EDT
I'm strongly in favour of leaving the dependencies out here. The z* tools are rather auxiliary tools, nothing necessary for basic gzip operation. Whoever wants to use zdiff, zless, etc. probably wants to use diff and less as well and so he should expect the requirement to make sure he has the diffutils and less packages installed.
Comment 7 Fedora Admin XMLRPC Client 2010-11-29 08:34:01 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Vojtech Vitek 2011-04-27 04:06:33 EDT
I'm closing this bz as resolved (see Comment 2).

From my point of view, it is really _not necessary_ to have dependency on the tools just because of z{wrappers}. Gzip itself, as de/compressor utility, has no relation to those in it's normal use.

Feel free to reopen the bug once there is one of these "advanced" RPM dependency types implemented:
* Recommends
* Suggests
* Extends
* ...<whatever>..
Comment 9 Robert Scheck 2012-11-04 06:53:51 EST
Sorry...removing a dependency in favor of an error message is not a solution
to me, folks. And it is not user-friendly, because not everybody has fscking
and annoying PackageKit-command-not-found plugin that catches every typo, too.

Note You need to log in before you can comment on or make changes to this bug.