Bug 62962 - Webalizer depends on webserver capability
Webalizer depends on webserver capability
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: webalizer (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-08 10:39 EDT by Tethys
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 08:20:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2002-04-08 10:39:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
The webalizer RPM has a dependency on the webserver capability.
This is invalid. Log file analysis is completely separate to actually
serving the pages. My logs, for example, arrive at a logging server
via syslog. When trying to install webalizer to analyze them, I had
to use --nodeps, because that machine doesn't have apache (or any
other webserver) installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Build a base machine, without a webserver installed
2. rpm -Uvh webalizer-2.01_06-11.i386.rpm
3.
	

Actual Results:  Install fails because the webserver capability isn't satisfied.

Expected Results:  Install should succeed.

Additional info:

This isn't a bug with webalizer itself, it's just a packaging error.
Comment 1 Ngo Than 2002-06-21 14:32:34 EDT
it's fixed in 2.01_10-5
Comment 2 Stephen 2004-11-17 00:27:07 EST
It's broken in 2.01_10-25 i.e. FC3.  To install webalizer it also
wants to install apr, apr-util, httpd, httpd-suexec.

I just want to analyze the logs from my colocated server..!

Note You need to log in before you can comment on or make changes to this bug.