Bug 629753 - [abrt] evolution-2.31.90: SIGSEGV in mail_send_message
[abrt] evolution-2.31.90: SIGSEGV in mail_send_message
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:0a9343f1199fd8e5f528eb93a5f...
:
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-09-02 16:52 EDT by Henry Kroll
Modified: 2010-10-01 10:27 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-mapi-0.31.92-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-27 04:40:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (88.42 KB, text/plain)
2010-09-02 16:52 EDT, Henry Kroll
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 630700 None None None Never

  None (edit)
Description Henry Kroll 2010-09-02 16:52:02 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: evolution
component: evolution
crash_function: mail_send_message
executable: /usr/bin/evolution
kernel: 2.6.36-0.10.rc2.git4.fc15.x86_64
package: evolution-2.31.90-1.fc14
rating: 4
reason: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1283460600
uid: 500

How to reproduce
-----
1. send mail using sendmail or smtp (the only options)
2. sit back
3. bingo!
Comment 1 Henry Kroll 2010-09-02 16:52:05 EDT
Created an attachment (id=442723)
File: backtrace
Comment 2 Christopher Beland 2010-09-10 15:21:08 EDT
Package: evolution-2.31.90-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Crashes reliably when sending mail via SMTP
Comment 3 Christopher Beland 2010-09-10 15:42:44 EDT
Package: evolution-2.31.90-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Hit Send/Receive hoping that missing IMAP subfolders would show up
Comment 4 Christopher Beland 2010-09-16 19:53:14 EDT
Nominating as a Fedora 14 Final release blocker based on the criterion: "All applications listed under the Applications menu must withstand a basic functionality test and not crash after a few minutes of normal use."
Comment 5 Milan Crha 2010-09-27 03:33:06 EDT
Thanks for a bug report. From the code and backtrace reading I see it failed to open the Sent folder configured for the account, and because the open-folder-function didn't return error, then later was dereferenced a NULL pointer, leading to this crash.
Comment 6 Milan Crha 2010-09-27 03:46:08 EDT
I filled an upstream bug report for this:

https://bugzilla.gnome.org/show_bug.cgi?id=630700
Comment 7 Milan Crha 2010-09-27 04:35:43 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=2491102

I just built evolution-2.31.92-2. Please test it there. Thanks in advance.
Comment 8 Fedora Update System 2010-09-27 11:51:18 EDT
libopensync-plugin-evolution2-0.22-8.fc14,pidgin-2.7.3-4.fc14,evolution-mapi-0.31.92-1.fc14,evolution-exchange-2.31.92-1.fc14,openchange-0.9-8.fc14,evolution-2.31.92-2.fc14,evolution-data-server-2.31.92-1.fc14,gtkhtml3-3.31.92-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libopensync-plugin-evolution2-0.22-8.fc14,pidgin-2.7.3-4.fc14,evolution-mapi-0.31.92-1.fc14,evolution-exchange-2.31.92-1.fc14,openchange-0.9-8.fc14,evolution-2.31.92-2.fc14,evolution-data-server-2.31.92-1.fc14,gtkhtml3-3.31.92-1.fc14
Comment 9 Fedora Update System 2010-09-30 02:13:29 EDT
evolution-mapi-0.31.92-1.fc14, evolution-exchange-2.31.92-1.fc14, openchange-0.9-8.fc14, evolution-data-server-2.31.92-1.fc14, gtkhtml3-3.31.92-1.fc14, gnome-panel-2.31.90-5.fc14, libopensync-plugin-evolution2-0.22-8.fc14, pidgin-2.7.3-4.fc14, evolution-2.31.92-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Christopher Beland 2010-10-01 10:27:54 EDT
Confirming that I can now send email without crashing in evolution-2.31.92-2.fc14.x86_64.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.