Bug 62977 - RH installer copies bootloader into incorrect EFI directory
RH installer copies bootloader into incorrect EFI directory
Status: CLOSED DUPLICATE of bug 63328
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-08 16:33 EDT by Jenna Hall
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-08 16:33:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jenna Hall 2002-04-08 16:33:06 EDT
Description of Problem:
The IA-64 Red Hat installer copies the EFI bootloader and the kernel onto the 
root EFI partition.  This violates the EFI specification as stated below.  Is 
there any plan to move the bootloader and related files to a subdirectory under 
the root EFI partition?

11.2.1.3 Directory Structure
"An EFI system partition that is present on a hard disk must contain an EFI 
defined directory in the root directory.  This directory is named EFI.  All OS 
loaders and applications will be stored in subdirectories below EFI.  
Applications that are loaded by other applications or drivers are not required 
to be stored in any specific location in the EFI system partition.  The choice 
of the subdirectory name is up to the vendor, but all vendors must pick names 
that do not collide with any other vendor's subdirectory name.  This applies to 
system manufacturers, operating system vendors, BIOS vendors, and third party 
tool vendors, or any other vendor that wishes to install files on an EFI system 
partition.  There must also only be one executable EFI image for each supported 
CPU architecture in each vendor subdirectory.  This guarantees that there is 
only one image that can be loaded from a vendor subdirectory by the EFI Boot 
Manager."

Version-Release number of selected component (if applicable):
any current IA-64 RH release

How Reproducible:
N/A

Steps to Reproduce:
1. N/A
2. 
3. 

Actual Results:
Bootloader and related files (config files, kernel) are copied into the root 
EFI directory by the installer.

Expected Results:
Bootloader and related files (config files, kernel) should be copied into a 
subdirectory under the root EFI directory by the installer.


Additional Information:
Comment 1 Michael Fulbright 2002-04-15 17:07:10 EDT

*** This bug has been marked as a duplicate of 63328 ***

Note You need to log in before you can comment on or make changes to this bug.