Bug 629814 - preupgrade does not account for transaction size when computing if enough disk space is available
preupgrade does not account for transaction size when computing if enough dis...
Status: CLOSED DUPLICATE of bug 511878
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-02 23:29 EDT by Eric Blake
Modified: 2010-12-12 12:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-12 12:45:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Blake 2010-09-02 23:29:46 EDT
Description of problem:
For the preupgrade test day, I tried to upgrade an F12 VM with only a 6GiB disk available.  The disk was nearing capacity (virt-df disk.img prior to the preupgrade attempt showed:
 fedora_12:/dev/vg_vmfedora12/lv_root   4320944    2942248    1334796   69%
Preupgrade warned during the download process that I was running low on space, and needed to clear up about 60MiB before preupgrade could complete.  I did so, by cleaning up just enough, then preupgrade finished and let me reboot.  But when running anaconda on the reboot, the system complained that / needed 700MiB more space to complete the transaction, and failed to perform the upgrade.

Version-Release number of selected component (if applicable):
preupgrade-1.1.7-1.fc12.noarch

How reproducible:
didn't try to reproduce, but probably rather easy, given enough disk space tweaking

Steps to Reproduce:
1. fill the / partition of the disk with a filler file
2. run preupgrade; when it complains about insufficient space, reduce the size of the filler file by about 1MiB more than what preupgrade complained about
3. once preupgrade is happy, proceed to reboot
  
Actual results:
anaconda complained that there was insufficient space to complete the transaction; the upgrade was aborted, and after Ctrl-C, I was rebooted into F12

Expected results:
preupgrade should be able to account for the additional disk space that will be required by the anaconda transaction size; it's not just how much space is needed to hold all the upgrade rpms, but how much those rpms will expand during installation prior to the rpm cleanups.  preupgrade should be able to give the user an accurate count of how much disk space is necessary for a completely successful upgrade.

Additional info:
I ended up using virt-resize to grow the VM disk, then after pvresize and friends, had a larger /, at which point repeating the entire exercise passed.
Comment 1 Andre Klapper 2010-12-12 09:38:53 EST
Same as bug 511878 - please mark as dup.
Comment 2 Nicola Soranzo 2010-12-12 12:45:52 EST

*** This bug has been marked as a duplicate of bug 511878 ***

Note You need to log in before you can comment on or make changes to this bug.