Bug 62990 - Anaconda crashes during upgrade when parsing fstab
Summary: Anaconda crashes during upgrade when parsing fstab
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2002-04-08 22:11 UTC by Jason Tibbitts
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Saved info from anaconda (42.42 KB, text/plain)
2002-04-08 22:12 UTC, Jason Tibbitts
no flags Details

Description Jason Tibbitts 2002-04-08 22:11:41 UTC
Anaconda crashes on upgrade of existing system while it is parsing the existing
/etc/fstab to mount the various partitions.

I will attach the complete saved bug info, but here are some useful excerpts:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 630, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/84820-i386/install//usr/lib/anaconda/text.py", line 427,
in run
  File "/usr/src/build/84820-i386/install//usr/lib/anaconda/dispatch.py", line
144, in gotoNext
  File "/usr/src/build/84820-i386/install//usr/lib/anaconda/dispatch.py", line
209, in moveStep
  File "/usr/src/build/84820-i386/install//usr/lib/anaconda/upgrade.py", line
223, in upgradeMountFilesystems
  File "/usr/src/build/84820-i386/install//usr/lib/anaconda/upgrade.py", line
65, in mountRootPartition
  File "/usr/src/build/84820-i386/install//usr/lib/anaconda/fsset.py", line
1551, in readFstab
IndexError: list assignment index out of range

Local variables in innermost frame:
loopIndex: {}
diskset: <partitioning.DiskSet instance at 82c2848>
line: karazm:/helium/var/mail /var/spool/mail

The complete fstab:

LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
LABEL=/cache            /cache                  ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
LABEL=/tmp              /tmp                    ext3    defaults        1 2
LABEL=/usr              /usr                    ext3    defaults        1 2
LABEL=/var              /var                    ext3    defaults        1 2
/dev/hde3               swap                    swap    defaults        0 0
karazm:/helium/var/mail /var/spool/mail         nfs rw,hard,intr,noac

Comment 1 Jason Tibbitts 2002-04-08 22:12:43 UTC
Created attachment 52784 [details]
Saved info from anaconda

Comment 2 Jeremy Katz 2002-04-08 22:20:04 UTC
Fixed in CVS

Comment 3 Red Hat Bugzilla 2006-02-21 18:48:41 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.