Bug 629933 - kernel 2.6.34.6-47.fc13.x86_64 does not boot on T60 (workaround: pci=nocrs)
kernel 2.6.34.6-47.fc13.x86_64 does not boot on T60 (workaround: pci=nocrs)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-03 06:12 EDT by Denys Vlasenko
Modified: 2010-09-08 21:17 EDT (History)
10 users (show)

See Also:
Fixed In Version: kernel-2.6.34.6-54.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-08 21:17:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvv output from Dell T3500 (39.83 KB, text/plain)
2010-09-04 14:11 EDT, Bob Arendt
no flags Details

  None (edit)
Description Denys Vlasenko 2010-09-03 06:12:05 EDT
After "yum update", which installed a new kernel, next boot greeted me with "dracut: FATAL: No or empty root= argument" and hung on boot.

I rebooted a few times to make sure it is reproducible, then rebooted into previous kernel, which booted ok.

I did not edit my grub.conf, and the sections for both new and old kernels look similar:

title Fedora (2.6.34.6-47.fc13.x86_64)
        root (hd0,0)
        kernel /vmlinuz-2.6.34.6-47.fc13.x86_64 ro root=/dev/mapper/vg_dhcp25227-lv_root rd_LVM_LV=vg_dhcp25227/lv_root rd_LVM_LV=vg_dhcp25227/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
        initrd /initramfs-2.6.34.6-47.fc13.x86_64.img

title Fedora (2.6.33.6-147.2.4.fc13.x86_64)
        root (hd0,0)
        kernel /vmlinuz-2.6.33.6-147.2.4.fc13.x86_64 ro root=/dev/mapper/vg_dhcp25227-lv_root rd_LVM_LV=vg_dhcp25227/lv_root rd_LVM_LV=vg_dhcp25227/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
        initrd /initramfs-2.6.33.6-147.2.4.fc13.x86_64.img
Comment 1 Chuck Ebbert 2010-09-03 09:16:24 EDT
Try adding "pci=nocrs" to the boot options.
Comment 2 Bob Arendt 2010-09-03 12:49:31 EDT
I had the same issue, same kernel and 64-bit system.  Changing the BIOS SATA setting from ACHI to ATA resulted in a successful boot & system operation.  I did not try "pci=nocrs".
Comment 3 Chuck Ebbert 2010-09-04 06:29:43 EDT
Did "nocrs" fix the problem?
Comment 4 Bob Arendt 2010-09-04 14:11:59 EDT
Created attachment 443082 [details]
lspci -vvv output from Dell T3500

Reverting the BIOS to SATA / AHCI, the hang recurred.  And "pci=nocrs" *did* fix the problem.  BTW, the machine is a Dell T3500 desktop using the latest A07 BIOS.  I've attached the lscpi -vvv output.
Comment 5 Chuck Ebbert 2010-09-05 05:42:14 EDT
Use of _CRS will be disabled by default in the next update.
Comment 6 Fedora Update System 2010-09-06 16:54:11 EDT
kernel-2.6.34.6-54.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/kernel-2.6.34.6-54.fc13
Comment 7 Bjorn Helgaas 2010-09-07 12:33:05 EDT
I think this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=620313
or possibly https://bugzilla.kernel.org/show_bug.cgi?id=17011

A complete dmesg log from the "pci=nocrs" boot would be enough to tell for sure.

There's a little more discussion and a debug patch at bug 620313.
Comment 8 Fedora Update System 2010-09-07 22:21:37 EDT
kernel-2.6.34.6-54.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kernel-2.6.34.6-54.fc13
Comment 9 Fedora Update System 2010-09-08 21:16:41 EDT
kernel-2.6.34.6-54.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.