Bug 629964 - Libdbi rpm loses data in GnuCash when using sqlite.
Summary: Libdbi rpm loses data in GnuCash when using sqlite.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libdbi
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-03 11:56 UTC by Mike Evans
Modified: 2013-07-03 03:32 UTC (History)
3 users (show)

Fixed In Version: libdbi-drivers-0.8.3-6.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-15 07:16:25 UTC


Attachments (Terms of Use)

Description Mike Evans 2010-09-03 11:56:24 UTC
Description of problem:
Problems with GnuCash sqlite losing transactions data.
See GnuCash bug 611936 and gnucash-devel thread "Bug 611936 and the 2.4.0 release" for a discussion of the bug.

How reproducible:
Only occurs with Fedora build of libdbi.

Steps to Reproduce:
1. Install libdbi and libdbi-drivers using YUM
2. Obtain latest GnuCash svn, build and install. 
3. Save to sqlite, close GnuCash, re-open saved data.
  
Actual results:
Loss of data as described in thread and GnuCash bug.

Additional info:
Removing rpm libraries and compiling from source using "make debug" cures the problem. Apparently this does not occur with other other library distributions.

Apologies for referring to GnuCash mailing list and bugzilla but all the info is already there.

Comment 1 Tom Lane 2010-09-03 13:56:04 UTC
Um ... could you provide URLs, rather than expecting me to know where to find this stuff?  Assume I've never heard of GnuCash.

I suppose there's probably a version of GnuCash available in Fedora.  Does the problem happen with that, rather than a custom build?

Comment 2 Mike Evans 2010-09-03 15:25:55 UTC
Oh, sure sorry.

https://bugzilla.gnome.org/show_bug.cgi?id=611936
And the start of the thread is at;
https://lists.gnucash.org/pipermail/gnucash-devel/2010-August/029141.html

It is rather a long thread however.

This applies to the upcoming release of GnuCash 2.4, in development at 2.3.14 at the moment.  
The FC12 package is for Gnucash version 2.2, gnucash-2.2.9-4.fc12.i686 and the sqlite database is not part of that package.  I can't comment on later Fedora releases I'm afraid.

Comment 3 Tom Lane 2010-09-03 18:32:16 UTC
Hm, so -fno-fast-math makes it go away?  Seems a bit odd, but I'm more than willing to nuke any "optimization" option that upstream is unwilling to include in their debug builds.

Comment 4 Tom Lane 2010-09-03 18:39:36 UTC
I tried this on my Fedora 13 x86_64 box, using the gnucash that comes with F13 (gnucash-2.3.13-1.fc13.x86_64), and didn't see a problem.  So either I'm testing wrongly, 2.3.13 doesn't have the problem, or it only occurs on 32-bit builds.  Any thoughts which is the most likely path to pursue?

Comment 5 Tom Lane 2010-09-03 23:58:16 UTC
... and the answer is that it's 32-bit-specific, or at least I can reproduce the data corruption on i686 F-13 and not x86_64.  I don't see the other warnings that were mentioned in the upstream thread, though.

Getting rid of -ffast-math does appear to fix it.  I'll spin new RPMs with that fix shortly.  Please test.

Comment 6 Fedora Update System 2010-09-04 00:49:29 UTC
libdbi-drivers-0.8.3-6.fc13,libdbi-0.8.3-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/libdbi-drivers-0.8.3-6.fc13,libdbi-0.8.3-4.fc13

Comment 7 Fedora Update System 2010-09-04 00:49:33 UTC
libdbi-drivers-0.8.3-6.fc12,libdbi-0.8.3-4.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/libdbi-drivers-0.8.3-6.fc12,libdbi-0.8.3-4.fc12

Comment 8 Fedora Update System 2010-09-04 00:49:38 UTC
libdbi-drivers-0.8.3-6.fc14,libdbi-0.8.3-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libdbi-drivers-0.8.3-6.fc14,libdbi-0.8.3-4.fc14

Comment 9 Mike Evans 2010-09-04 08:29:39 UTC
(In reply to comment #5)
> ... and the answer is that it's 32-bit-specific, or at least I can reproduce
> the data corruption on i686 F-13 and not x86_64.  I don't see the other
> warnings that were mentioned in the upstream thread, though.
The other warnings I was getting was (I think) due to my GnuCash SVN tree getting corrupted, somethind I'd done elsewhere.  It went away when I check out a fresh SVN tree. 
> 
> Getting rid of -ffast-math does appear to fix it.  I'll spin new RPMs with that
> fix shortly.  Please test.
Will do.

Comment 10 info@kobaltwit.be 2010-09-04 10:20:18 UTC
Tom,

Thank you for your incredibly swift response. I have tested the updated packages on Fedora 13 i386 and can confirm they fix this bug.

Is there anything I can do to speed up the process of getting them included in the official updates ?

Comment 11 Tom Lane 2010-09-04 15:45:53 UTC
(In reply to comment #10)
> Is there anything I can do to speed up the process of getting them included in
> the official updates ?

Once the packages are pushed to updates-testing, you can add +1 karma to them (add a "works for me" comment to their bodhi page, which will have a link here once the push occurs).

Comment 12 Mike Evans 2010-09-05 09:35:07 UTC
This works for me on FC12 using GnuCash.  Thanks Tom for very quick work.

Comment 13 Fedora Update System 2010-09-06 05:15:00 UTC
libdbi-drivers-0.8.3-6.fc14, libdbi-0.8.3-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libdbi-drivers libdbi'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/libdbi-drivers-0.8.3-6.fc14,libdbi-0.8.3-4.fc14

Comment 14 info@kobaltwit.be 2010-09-07 09:12:42 UTC
Will this be pushed to FC13 as well ? Or should I add a worksforme comment on the FC14 admin page ? I have only tested it in FC13 so far.

Comment 15 Tom Lane 2010-09-07 14:21:24 UTC
Yes, it's in the queue for F13 and F12 too.  What with the holiday weekend, I wasn't expecting to see *any* of those pushes happen before today ;-).  Have patience, it should happen in the next day or two.

Comment 16 Fedora Update System 2010-09-15 07:16:20 UTC
libdbi-drivers-0.8.3-6.fc14, libdbi-0.8.3-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-09-15 22:32:41 UTC
libdbi-drivers-0.8.3-6.fc12, libdbi-0.8.3-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-09-15 22:33:17 UTC
libdbi-drivers-0.8.3-6.fc13, libdbi-0.8.3-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.