Bug 629970 - can't build glibc-2.12.90-8 on s390x - endless loop on tst-longjmp_chk2
can't build glibc-2.12.90-8 on s390x - endless loop on tst-longjmp_chk2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
14
s390x Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2010-09-03 08:12 EDT by Dan Horák
Modified: 2016-11-24 10:36 EST (History)
3 users (show)

See Also:
Fixed In Version: glibc-2.12.90-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 02:15:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2010-09-03 08:12:43 EDT
I can't build glibc-2.12.90-8 for s390x and s390 because the build logs get filled with repeated "in signal handler/on alternate stack" messages and this continues for hundreds of MB (I got even a 2GB+ log), normal build log is about 400 KB so I cancel the build. Please see the URLs for more details.

wrong/canceled build:
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=203936

I was able to do a successful build of 2.12.90-7 a month ago and its results are at http://s390.koji.fedoraproject.org/koji/buildinfo?buildID=34963
If I can trust IRC logs then it was with kernel -44.1.el6 on the builders and cpuplugd disabled.

I've tried multiple kernels
kernel-2.6.32-44.1.el6.s390x
kernel-2.6.32-71.el6.s390x

and also tried disabling the cpuplugd daemon (enabled by default) that turns cpus online/offline depending on the load.


interesting parts of the logs:

glibc-2.12.90-7
===============
+ echo ====================TESTING DETAILS=================
++ sed -n 's|^.*\*\*\* \[\([^]]*\.out\)\].*$|\1|p' build-s390x-linuxnptl/check.log
=====/builddir/build/BUILD/glibc-2.12-85-g73507d3/build-s390x-linuxnptl/debug/tst-longjmp_chk2.out=====
+ for i in '`sed -n '\''s|^.*\*\*\* \[\([^]]*\.out\)\].*$|\1|p'\'' build-*-linux*/check.log`'
+ echo =====/builddir/build/BUILD/glibc-2.12-85-g73507d3/build-s390x-linuxnptl/debug/tst-longjmp_chk2.out=====
+ cat /builddir/build/BUILD/glibc-2.12-85-g73507d3/build-s390x-linuxnptl/debug/tst-longjmp_chk2.out
not on alternate stack
 in signal handler
 on alternate stack
============


glibc-2.12.90-8
===============
+ cd ..
+ echo ====================TESTING DETAILS=================
++ sed -n 's|^.*\*\*\* \[\([^]]*\.out\)\].*$|\1|p' build-s390x-linuxnptl/check.log
=====/builddir/build/BUILD/glibc-2.12-118-ga7ab6ec/build-s390x-linuxnptl/debug/tst-longjmp_chk2.out=====
+ for i in '`sed -n '\''s|^.*\*\*\* \[\([^]]*\.out\)\].*$|\1|p'\'' build-*-linux*/check.log`'
+ echo =====/builddir/build/BUILD/glibc-2.12-118-ga7ab6ec/build-s390x-linuxnptl/debug/tst-longjmp_chk2.out=====
+ cat /builddir/build/BUILD/glibc-2.12-118-ga7ab6ec/build-s390x-linuxnptl/debug/tst-longjmp_chk2.out
not on alternate stack
 in signal handler
 on alternate stack
  in signal handler
  on alternate stack
   in signal handler
   on alternate stack
    in signal handler
    on alternate stack
    ...........
Comment 1 Andreas Schwab 2010-09-07 06:13:49 EDT
I cannot reproduce that on RHEL5.
Comment 2 Dan Horák 2010-09-07 08:01:54 EDT
This issue first occurred when we switched the builders to RHEL6 Beta2. Let me know (I'm "dhorak" on internal IRC) if you would need access to one of the Fedora builders.
Comment 3 Dan Horák 2010-09-13 15:05:53 EDT
build of glibc-2.12.90-10 failed with the same problem, this time only on s390 and s390x was OK, see http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=205809 for details
Comment 4 Andreas Schwab 2010-09-14 09:23:08 EDT
I'm unable to reproduce that on RHEL6 either.
Comment 5 Dan Horák 2010-09-14 11:44:34 EDT
Seems it's not 100% reproducible. I did 2 builds (s390x) today in the Fedora 14 chroot running on top of RHEL6 and the first run successful, but in the second one I got the endless loop.
Comment 7 Fedora Update System 2010-09-27 11:48:55 EDT
glibc-2.12.90-13 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/glibc-2.12.90-13
Comment 8 Fedora Update System 2010-09-27 16:07:23 EDT
glibc-2.12.90-13 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glibc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/glibc-2.12.90-13
Comment 9 Dan Horák 2010-09-28 04:28:17 EDT
Builds and runs fine on s390(x), thanks for the fix.
Comment 10 Fedora Update System 2010-09-28 13:32:07 EDT
glibc-2.12.90-14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glibc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/glibc-2.12.90-14
Comment 11 Fedora Update System 2010-09-30 02:15:21 EDT
glibc-2.12.90-14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.