Bug 63004 - RFE: pass proxy configuration to rhn_register
RFE: pass proxy configuration to rhn_register
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-08 23:53 EDT by Chip Turner
Modified: 2015-01-07 18:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 05:39:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chip Turner 2002-04-08 23:53:12 EDT
It would be nice to be able to pass proxy config to rhn_register from the
applet, so that the user only has to enter it once.
Comment 1 Adrian Likins 2002-04-09 14:33:56 EDT
persistent or not?

ie, if you pass args to me, do I write them to the config file,
or use them for that session only?

I assume you want the former, though the latter is more consistent
with the way commandline arguments typically work.
Comment 2 Adrian Likins 2002-04-09 14:59:21 EDT
does:

new install, no commandline argument
   exp: fire up config dialog, record proxy settings and user them, write
networkSetup=1

new install, proxy specified on commandline:
  exp: no config dialog, record proxy settings and user them, write networkSetup=1

existin install (networkSetup=1), no commandline bahaviour:
  exp: no config dialog, use proxy settings if available

existing install (networkSetup=1), proxy specified on commandline:
  exp: no config dialog, use proxy settings, dont record



sound like what you'd expect it to do?
Comment 3 Adrian Likins 2002-04-09 15:43:00 EDT
I changed my mind, if you specify an proxy, it gets recorded
as the default proxy.

A little ugly, but doing otherwise will change too much code
Comment 4 Adrian Likins 2002-04-09 16:13:24 EDT
changed my mind again, should exhibit the behaviour mentioned above
now.

should be fix in 2.7.13 or higher
Comment 5 Chip Turner 2002-04-09 16:42:53 EDT
well, rhn_register should only be run once, so sending it there should be
permanent.  as for up2date, I don't have much preference either way; I can
easily send proxy info to it, too, or not.

the semantic of "if info is on command line, set permanently" works for me. 
which is it now?  can I get RPMs of the latest to test?
Comment 6 Adrian Likins 2002-04-09 16:49:47 EDT
up2date will grab proxy info from rhn_registers config if
it hasnt been ran before.

I'd prefer not adding anymore commandline options to up2date if
at possible.

rpms will be in 7.3-HEAD as soon as porkchop unbreaks itself
Comment 7 Adrian Likins 2002-05-15 15:47:05 EDT
I belive this is implemented in a workable fashion. Closing.

Note You need to log in before you can comment on or make changes to this bug.